View capture to file creates clipping plane that isn't there

I am having problems saving out a high res image from my viewport. I set up the view like this:

That is how it looks if I manually take a screenshot^

If I use “ViewCaptureToFile” or “ViewCaptureToClipboard” and select any resolution higher than the viewport (which is too low for what I require) I get a mystery clipping plane effect:

Any ideas on how to get a high resolution output without chopping away the foreground of my perspective?
I have also tried it through exporting a layout with the 3D view, same problem.

Please help!

I recall this was reported and fixed not all that long ago.
Are you running V6 SR25?

Hello, was this resolved in the end?

I’m also having the same clipping problem when trying to use ‘ViewCaptureToFile’ at a higher res…

Hello, was this resolved in the end?

I’m also having the same clipping problem when trying to use ‘ViewCaptureToFile’ at a higher res…

I recently had the same issue, running the newest RH6 and RH7 for Mac…

This must be a different issue.
Can you please supply an example model and specific instructions so we can repeat the problem here?

Without that, there is No chance we can fix it.


Hallo John, I have the same problem also - all the time! Here and example.

TBN 20200915 basic 3D take out constelattion.3dm (13.3 MB)

I think this was fixed in a recent update:

Since 6.30 was released just yesterday, please download the Service Release Candidate (6.31) and see if this fixes it.
Preferences > General, Updates, change update frequency to “Service Release Candidate”, then click Check Now.

Be sure to switch your Update frequency back to Service Release so you don’t keep getting the untested builds.

Hi John,

I also am having the clipping plane crop up at higher resolution viewcapturetofile settings in both rhino 6 and the 7 wip - both of which are up to date from 11/4/2020 releases. Seems like for me perhaps it is an open subd issue in my case, although it clips on other solidsViewportclippingtest.3dm (5.4 MB)

See attached model.

This was fixed recently in

What service release are you running?

Hi John,

I also noticed this thread is rhino for mac, but i’m using rhino for windows.

Rhino 7 SR0 2020-11-4 - I am actually not 100% sure how you check that - when I go to rhino options under updates and statistics it says it is up to date and takes me to this link if I check now. I’m in the rhino BETA. I’m assuming that means release 7.0.20309.6003

And for rhino 6 its Rhino 6 SR31 2020-11-3 Rhino 6, 6.31.20308.11001

The “About” command will tell you which version and service release you’re running.
I tested the fix in V6 SR31 and V7 SR1

1 Like

Do I have to get an actual rhino 7 license to have SR1 instead of being in the 7 WIP?

Yes, or get a V7 eval and change the update frequency to Service Release Candidate.
It may make more sense to use V6 for now.

Appreciate your fast responses - i’ll try out the v7 eval.


I just tried it again in V6 SR31 with this larger file (I had clipped it down to send previously) and I still get the clipping plane if I change the scale or do custom proportions. I saved the exact camera view in it as well.

clipping plane test - v6 sr31.3dm (10.1 MB)

working well here, can’t reproduce.

if you go to tools>options>display modes>and look at your display mode… is it blue? if so that is a non default set up.

try resetting to default and roll again… did it get fixed? if not let us know.

Interesting! So puzzling.

I reset all view display styles to defaults


Still clipping when I do x2 scale instead of 1.

try select all and cut then open a new session of rhino and paste the data in a new window. Still there?

also check for updates and make sure you have the latest SR-

Definitely up to date with v6


I cut and paste into a new instance of v6 - still getting the clipping. Included a screenshot of settings and i’m in a render display setting.

if you set the scale to 1 and use viewport resolution does it help?

1 Like