ViewCaptureToFile from arctic view


To create certain stylistic images I combine a render with an arctic and an artistic view in photoshop. However when I use ViewCaptureToFile to create my arctic and artistic view something strange happens. It looks like there is a clipping plane in my scene when I use the arctic settings, however there is none in the file that I’m using. I looked through all the display settings that define my arctic view but couldn’t find anything. You can see in the added files that there is (apart from the style) different things displayed in the arctic and the artistic view. Off course I can just fix everything in photoshop, but it would be more efficient if I could solve the problem itselve.

Kind regards

Hi Reinout - can you please run SystemInfo in Rhino and post the results? Can you reproduce this with a simple file - boxes - and ground plane? If so please post that - if not, and you can share your real file please post that or send to to my (Pascal) attention, with a link back to this topic. This has been reported more than once but so far I have not been able to make it happen here.


Hi Pascal

I’ve tried it with a simpler model and had the same problem. I also added the result of the systeminfo. You can find the files via following link:


Hi Reinout - thanks - it all looks correct here so far - can you please check the NVidia website for a newer video driver for the Quadro P600? Yours is a couple of years old, and I would not be surprised if this is ‘driver related’.


Hi Pascal

I updated my video driver but the problem remains.


@DavidEranen - do you have an idea what is happening here? I cannot, so far, repeat the problem here.


When you run ViewCaptureToFile, are you manually specifying a higher resolution than your viewport?

I was yeah. I did the same with the viewport resolution and than the problem doesn’t occur. However I still think it’s strange that it only happens with the arctic view and not with the artistic view, any reasons for that? I noticed that artistic, unlike arctic, isn’t available until version 6 of rhino, maybe that has something to do with the problem?

I’m pretty sure there is a bug report for this clipping problem having to do with Arctic Display and ViewCaptureTo… at higher than viewport resolutions, but I’m having trouble finding it.

Here’s another report:

Are you using a Ground plane?

This may be fixed in the V6 Service Release Candidate.

Have you tried this in the V7 Beta?
It may have been fixed there.

Hi @reinout,

I can reproduce the problem and I created a YouTrack item:


Hello. Sorry for not been present. Professional matters.
I have been testing this Arctic display with “_viewcapturetofile” and it seems not working at all.
Now i have made a test with lots of nature vegetation blocks and the result is worst then ever.
Here the posts - first it rhino viewport / second is file capture result:
NOTE. I do not have clipping planes created. Even the Standard resolution screen doesnt work.
I do not have Rhino 7 Wip

Click on the YouTrack item in the post from David Eränen.
He can reproduce the problem and is working on it now.