Vector printing shaded display modes


#1

It seems we lost the ability to use the vector output option for printing details which use a shaded display (so you can get nice crisp lines where we can as well as have shaded details). Just wanted to check if this was going to come back at some point.

Thanks,
Sam


(John Brock) #2

This is one for @stevebaer


(Steve Baer) #3

Seems to be working for me, but I’m using the build of the minute and I’ve done a LOT of work on layouts over the last few days.

Hopefully the next build will work for you; if it doesn’t please let me know.


#4

I am still seeing this, and I’m having trouble finding what causes it to happen in certain display modes but not others. If a display mode is going to fail for printing shaded modes as vector, the preview also gets messed up in the print dialog. For me, all of the precanned modes worked except (rather ironically) wireframe, which shows incorrectly in the print dialog, but then prints correctly. Almost all of my display modes don’t work.

Here is what I expect (this is from my Shaded mode - Shaded.ini (11.4 KB) ):

and here is what it looks like when using one that has problems (called Rendered Gradient - Rendered Gradient.ini (11.0 KB) ) This will print wireframe.

Sam


(Steve Baer) #5

I think @jeff has been working on this issue.


(John Brock) #6

This went on the defect list last week.


(Jeff Lasor) #7

This has been fixed and committed today…

Thanks for reporting this.
-Jeff


#8

I’m still seeing vector printing failing in 6.0.15049.8591, 2/18/2015. The difference now is that I just see nothing in the print preview window instead of black.

Thanks,
Sam


(John Brock) #9

Please post a file with the print settings you’re using.
It’s working fine for me testing blind.


#10

File uploaded using the rhino3d.com/upload system.

Sam


#11

Reviving this from the dead :smile:

I’m seeing that curves / arcs are looking pretty rough on printing when using vector. For me, the line segments they are getting broken into are very noticeable.

I did figure out vector printing some of shaded display modes in wireframe though. I tried copying one of the pre-canned ones that worked as expected, then modifying it to exactly match one of mine (Rendered Gradient.ini attached above in this thread) and everything looked the same except in the not working ini, these values are set to “n”, and in the one that is working, it is set to “y”

ShadedPipelineRequired=n
WireframePipelineRequired=n

If I export the non-working display modes, delete them in Rhino, change these values, then re-import, it works (although I’m not sure how reliable this is because of the inability to keep display modes deleted). Is there a way to change them in Rhino directly?

Thanks,
Sam


#12

Reviving from the dead again.
When printing vector, details that are shaded will print wireframe. It is only on some of my display modes.

-EDIT-

Sorry, I though I was using a fixed display mode, in the manner that I described above.

Thanks,
Sam


(Steve Baer) #13

I’m confused. Should I interpret this as “nothing to see here, move along”?


#14

Sorry, yes, I resolved it. But it does seem odd that I’ve now had multiple display modes that didn’t import from V5 well.