V8 jagged lines display

I have another bizarre issue that, maybe, requires new thread.
This is what I am seeing after today’s R30 update to V7 and it affects all modes except Wireframe.

and this is how it looks in WiP:

Please notice how poor outlines are:
and they change colour when zoomed-in:

So, at the moment, neither V7 or V8 is usable to me.
To make sure I have restarted my machine and the V7 problem still occurs.

@Piotr the first issue is a know issue that should have been fixed, but apparently isn’t in 7.30 rc (I can’t repeat it in 7.30 build of the day though)
The issue you see in V8 is of course something else that needs more investigation.

ps: I split this topic, but it should actually have been splitted in two, The first issue is I think RH-74624 Shaded display material looks like semitransparent spilled gasoline.

Hi Gijs
It affects more than one style:




here’s another model that swallowed some LSD (shaded)

1 Like

same here

@ivan.galik can you send me your _SystemInfo and perhaps a simple model that illustrates the issue?

You can draw a circle and a line slightly out of ortho in the Top viewport, then set the shade mode to Rendered.
Looks like no antialiasing at all (but there is):

1 Like

@Charles just looking at your image on different monitors gives different results,
Do you see a difference when you tweak the appearance of lines with _TestWireThicknessScale?

@ivan.galik I asked you to send a model, maybe you cannot, in that case, can you inform what I am looking at, Are these gaps between panels, lines, something else?


I like 1.4.

I have noticed the same here:
V7 on left V8 on right:

And with wirethickness 1.4 in v8:

(Gijs make sure you view the original image when viewing images on the discourse so you aren’t affected by jpg compression)

What makes things complicated are these things:
It depends on you monitor scaling
It depends on gamma, typically shaded is not gamma corrected, rendered is.
Today I’ve made a comprehensive test to illustrate this, see attached
wire_scale.zip (10.6 MB)
I’m not sure if anything can be done to auto improve it for every display.

@Holo @Charles @ivan.galik what monitors are you using at which display scaling?

LG 43" 3840x1920 scaling 100%

This was on an AOC 3440x1440 at 100% scaling.
I have the same on a Dell with a slightly higher res too, also 100% scaling. Ill check on the fullhd laptop too.

First it should look ok at 100%.

Well, not many people are running Rhino on a 4K screen at 100%, you can really only do that on large monitors, or if there is no text on that monitor.
So a solution needs to be found for at least the most common scales.
Does 1.4 scaling work for you in all display modes?

It looks ok in Rendered, not so super in Shaded/Wireframe:

BTW, can you please tell me the default value of _TestWireThicknessScale in V7?
I’m not sure if I’ve ever played with it, and I want to make a fair comparison.

What about WireThicknessScale per shade mode?

should be 1

Maybe, but first some investigation is needed, I hope there is a simpler way than adding yet another setting. I’ve logged this issue under RH-75021 AA in different wire scaling and display modes

Looks ok in V7:

Rhino 8 SR0 2023-5-30 (Rhino WIP, 8.0.23150.10305, Git hash:master @ a7f16b00e39d903cb1a0d15887ca9d9d8eec1492)
License type: Commercial, build 2023-05-30
License details: Cloud Zoo
Expires on: 2023-07-14

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 11-26-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 527.37
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-26-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\Ivan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AntFarm\0.0.20-beta\AntFarm.rhp “AntFarm”
C:\Users\Ivan\AppData\Roaming\McNeel\Rhinoceros\BlockEditNew\BlockEditNew.rhp “BlockEdit”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23150.10305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.23150.10305

jagged curves.3dm (205.9 KB)

I’m surprised you say that looks ok, it looks super jagged to me. The moiré pattern is a clear indicator.

@ivan.galik thanks, I can see a slight jaggedness in those lines in shaded view, but not in rendered. I certainly don’t see the jaggedness you are showing. Did you find a proper multiplier with _TestWireThicknessScale that works for you?
I’m a little confused at what is happening. Are the curves in your original file white, or do they switch color, like @Piotr was showing?

I see the near vertical/horizontal lines look ok.
Not super duper, just ok.