Jagged curved edges help, plz

This has been driving me crazy, so I’m going to finally take the time to post and hope to get some help figuring this out. The pictures pretty much say it all. I’ll have a curved surface that looks fine in wireframe, but when shaded or rendered, they become jagged. Sometime rebuilding helps, but usually not. Any ideas as to what’s going on?

It’s a coarse render mesh.
Go into Options - Mesh and change it to Smooth and slower.
You’ll see it improves.
It’s just eye-candy so it appears to be shaded.
It has nothing to do with the accuracy or smoothness of the surfaces themselves.

Here’s the low-down:

I appreciate the info., and I’m glad to hear that the accuracy is still there. My settings are already set to “smooth and slower”. It is odd that it’s not until I join smaller geometry that appears smooth to larger geometry that the jaggy-ness shows up. Is there some limit on the size of geometry that, once surpassed, defaults to a courser mesh?

Can you post the objects, un-joined?



If you want it to fit better, switch to the custom mesh and set and angle to 1 or 2 degrees.
Something to be aware of though, is the better the mesh fits, the slower the display performance will be.
Whey run slowly just for pretty pictures? I rarely run in a shaded display. Al most always in Wireframe just for performance.

Ready through the second link for more details on how meshes work in Rhino.

Thank you for those links, John. Really helpful. I work primarily in wireframe, too, but do check things in shaded frequently. I played with the settings, as you suggested, and its looking much more "pretty picture :wink: Thanks, again!

Bless this thread, huge life saver!
This is what I was just experiencing.
Thanks everyone!

Hmmm…the “before” picture doesn’t look like the problem is mesh settings at all. It looks more like a display glitch from the object being miles away from the origin. Something seems screwy about that model.

Hi John - have the same problem and can’t fix it - please help

geometry looks fine in wireframe mode - horrible in pen/artistic/ enscape

Hello - how does Shaded mode look?


looks fine

any idea what it could be?

Hello - can you show what the camera coordinates are? in Properties, with no selection.


Yeah… these numbers are very large:

Try moving all your objects closer to the world origin, and ClearAllMeshes for good measure.


wow! it did it!
Thank you SO MUCH Pascal!
much appreciated