V6 : Real disappointment : Today I stop using it and rollback to V5

I really love Rhino. I moved from 4 to 5 with fun and willing to help to improve the software.
But since I upgraded to 6, it is really painful. It slows too much my workflow.
I don’t know if the integration of Grasshopper (which I use everyday) is part of the problem.
It is constantly crashing.
This time I won’t spend time to describe each crash.
For me, it is clearly in beta. It is not a professional tool at this state.
I rollback to V5.


1 Like

I’m sorry you’re choosing to give up instead of working through the problems to make Rhino V6 better.
Most users are finding V6 much better on many levels.

Without specifics, we can’t help.

If you don’t mind, please run the SystemInfo command and post the results.
That’s as good a place to start as any.

@lahos, I’m a very critical person when it comes to professional (or any other) software.

For me Rhino6 works 100 times better than v5, I’ve been working with Rhino since its version 3. Rhino6 is by far the best so far in any aspect. Yes it has its weaknesses but these are in general, I found no weaknesses comparing it with v5.

Perhaps you should describe the problems you face. I’m sure there’s a solution if your GH algorithms has worked with v5.

I have not a better opinion on v5 to v6 that I had with v4 to v5, but I’m interpellate by

I’ve no crashs

@lahos, at this day, Rhino 6 works the same way as Rhino 5 at the beginning (some bugs appear, but we can produce with).

It may be produced by your system. Inform the McNeel team, because if it’s your system, in two years you would have the same problem.

There is a known Grasshopper crash that we just discovered and fixed over the weekend. This fix should be available in the next service release available on Tuesday.

Thanks. I’ll give it a try.

I agree on all improvements of Rhino 6 (especially the rendering and parallel processing of gh).

I don’t how other users work with Rhino.
I can only describe my context.

  • I have 2 to 5 projects opened at the same time and all the time.
  • I code in gh c#, gh python and rhino python.
  • I use gh libraries (Firefly, Putterfish, Kangaroo, Squid, LunchBox, Ivy, Human,TT Toolbox, gHowl, StudioAvw).

I had crashes with v5 and losses and I managed to find workarounds.
When a tool misbehaves you can find another way around, but when your soft quits with simple UI manipulations like open/close gh&rh&floating viewports or loads with unpredictable docks/panels positions,
it is more complicated to address the issues.
Since I upgraded to V6 in may, I felt that I drove a more beautiful and powerful car but with a few more hick-ups. I had to retrieve a more stable environment for a while.

Don’t worry, I truly love the mindset of Rhino / Grasshopper.
I will only take my time to migrate.


I would highly recommend trying the service release for 6.6 that will be made available tomorrow. It would also help us identify possible problems with your computer if you ran the SystemInformation command (on the help menu) and pasted the results back here on discourse.

@lahos we just released 6.6 today which has the crash fixes that I mentioned in it.

I haven’t had many crashes but Rhino 6 feels a bit like a beta still. In each new version some bugs are fixed and new bugs are created.

Like right now it seems I can’t right click on the middle Point in the Gumball to change the gumball alignment anymore. I could do without the new bugs added each update, well guess we get them as a bonus. At least they haven’t been anything too serious so far.

Seems to be working here, hold down Ctrl, click on the center point, let up on Ctrl and drag the center where you want… (6.7.18177.12461, 26-06-18)

Actually that wasn’t what I was trying to do. I wanted to orient the gumball to the object instead of the CPlane. I used to be able to do that by clicking on the middle Point in the gumball to open a small menu. It doesn’t seem to be working anymore, I’ve tried holding down Alt, Shift or Ctrl and pressing each mouse button, It’s not possible anymore.

Sometimes I don’t remember how I do certain things, it’s just muscle memory. Like for some passwords I don’t even remember the password I just “remember” the order I press the buttons on the keyboard. It’s like that when I log into WoW since I’ve done it some many times. And it’s like that with some functions in Rhino, when It doesn’t work I don’t know if it’s bugged or if I’m not doing it right.

In V5, the gumball had a “tail” with a little white circle for accessing “settings”. It’s still there in V6, but it’s off by default. Right clicking in the Gumball pane in the status bar gets you all settings and there is a link to the page in options as well. There you can turn on the “menu ball” by setting the size to something other than 0.

Did this work in 6.5? @pascal or @mikko, can you repeat this?

We treat regressions as critical bugs that should delay shipping of a new service release. This is why we have a four week stabilization period with release candidates. Of course something can slip by, but we try our hardest not to let that happen.

I get the menu here by right-clicking on any of the gumball controls. However, @Mikael_Liback, - the normal right-click delay has been added to this menu - at users’ request. So there is a 250ms delay before the menu shows, by default. This can be set in Options > Mouse page - I like 150ms better myself. You could also re-enable the bumball menu ball in Options > Modeling aids > Gumball page > ‘Menu ball size’.

Does any of that help?


1 Like

Not here - latest 6.7 RC…

Hi Mitch - what about with a delay? Click-n-hold?


Nope… tried that… Ah, wait, I have “delayed context menus” turned off… works if I turn it on.

Ah, ok - right, that comes into play now too - that should be on by default though so hopefully not too many others won’t run into that.