V6 Points See through

unhandled
v6_display

#1

Hello,

I tested the WIP 19. Sep 17 with some large architecture models and its very impressive how fast and responsive the display works.
But I have in some cases points displays even when they were supposed to be behind some other objects.
Also the edge thickness set to 1 px displays much bigger than in V5. This would be great to have more subtle edges.

Tom


(David Eränen) #2

Hi @TomWue,

Are you able to repeat this with a small model? If at all possible, would you be able to send the file to us (https://www.rhino3d.com/upload)?

-David


#3

Hi David,

I sent you a file via upload. I saved small and it seems better when reopening but when I zoom close to a window part the points from the back appear again.

Another issue I just double checked it the zoom responsivness. I have a very smooth and quick response on a machine with an old GTS 450 but very slow zoom reaction on a new Quadro P2000 (Dynamic Streaming) but rotation is fine!

Tom


(David Eränen) #4

@TomWue,

I got your file and I was able to reproduce the problem. I have created a YouTrack bug-report, but it’s not visible publicly due to your file being attached to it.

Regarding the zoom responsiveness - is this in Shaded mode? Or Rendered? Are you zooming in with the mouse wheel, or by holding Ctrl + Right mouse button?

-David


#5

Hi David,

The zoom responsivness is in shaded mode (little less in rendered) but both with the mouse wheel. Ctrl+rmb works quite well. In general it feels also in rotation that there is some kind of latency which is definitly disturbing while zooming.

Tom


#6

Another question,
is there an option to disable the automatic viewport degrading (switch to wireframe) for heavy scenes?


(David Eränen) #7

Yes, go to Tools -> Options… -> View

Dynamic redraw: Frames per second. The default value is 5.0, which means that if the display drops under 5.0 frames per second the display will degrade until it goes over 5.0 FPS.

If you don’t want the display to degrade under any circumstances, set the value to 0.0.


(David Eränen) #8

@TomWue Do you have the latest WIP?


(Pascal Golay) #9

Hi All - I tested this with Tom’s file in the latest WIP, and was able to reproduce the problem (though at a closer zoom than in the image). Anyway it is on the bug-heap.

thanks,

-Pascal


#10

Dear all,

I installed Rhino6 (hey cool out now! surprise, surprise!).
I am still facing the zoom responsivness issue:

… I just double checked it the zoom responsivness. I have a very smooth and quick response on a machine with an old GTS 450 but very slow zoom reaction on a new Quadro P2000 (Dynamic Streaming) but rotation is fine!

The zoom responsivness is in shaded mode (little less in rendered) but both with the mouse wheel. Ctrl+rmb works quite well. In general it feels also in rotation that there is some kind of latency which is definitly disturbing while zooming.

Could you please let me know how if there is any fix or recommended setting to make it work.

Best
Tom


(Pascal Golay) #11

Hi Tom - this is a shot in the dark but I’ve heard of several quite different ‘weird’ behaviors that appear to be due to ‘gpu tessellation’ in Options > View > OpenGL page. Normally you’d want that checked but just as a test, uncheck and see if anything changes.

-Pascal


#12

Hi Pascal,

thanks for the fast reply. But I tried this before. Actually the framerate is lower without gpu tessellation and the problem with the jurky zoom and rotation is not getting any better!

Any other suggestions?
Drivers are updated to the latest release…

Best
Tom


(Pascal Golay) #13

Hi Tom - I do not have any great ideas - can you please run SystemInfo in Rhino (6) and paste the results here? Also, what monitors do you have hooked up?

-Pascal


#14

Hi Pascal,

the monitor is a Samsung S24E650BW 24" (1920x1200px).
Here is the SystemInfo:

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @ c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro P2000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Best,
Tom


#15

Hello, any news about this topic?


(David Eränen) #16

Hi @TomWue,

So do I understand you correctly that this happens in Shaded mode also? Are your display settings set to their defaults?

Does it get fixed if you disable “Auto adjust camera target after Pan and Zoom”? (You can find it in Rhino Options -> View).

-David


#17

Hi David,

I just found time to test again after I set up the machine completely new - out of other reasons - without any change for the view problem!
Yes, the shaded view is used with default settings and the “Auto adjust camera target after Pan and Zoom” switched of is unfortunetly not solving the case!

Best
Tom


(David Eränen) #18

@Pascal,

Earlier in this thread you said you could reproduce this issue. Is that still the case?

Maybe I’m doing something wrong. @nathanletwory and @BrianJ -
are you able to reproduce?


(Brian James) #22

I tested the model here in the 6.2 SRC and I don’t see point objects through the model in Shaded mode. I also don’t have any zooming issues if that is also one of the current problems.