Rhino 6 slow with nVidia P2000

unhandled

#1

Hi David,

I sent you a file via upload. I saved small and it seems better when reopening but when I zoom close to a window part the points from the back appear again.

Another issue I just double checked it the zoom responsivness. I have a very smooth and quick response on a machine with an old GTS 450 but very slow zoom reaction on a new Quadro P2000 (Dynamic Streaming) but rotation is fine!

Tom


V6 Points See through
#2

Hi David,

The zoom responsivness is in shaded mode (little less in rendered) but both with the mouse wheel. Ctrl+rmb works quite well. In general it feels also in rotation that there is some kind of latency which is definitly disturbing while zooming.

Tom


#3

Another question,
is there an option to disable the automatic viewport degrading (switch to wireframe) for heavy scenes?


(David Eränen) #4

Yes, go to Tools -> Options… -> View

Dynamic redraw: Frames per second. The default value is 5.0, which means that if the display drops under 5.0 frames per second the display will degrade until it goes over 5.0 FPS.

If you don’t want the display to degrade under any circumstances, set the value to 0.0.


#5

Dear all,

I installed Rhino6 (hey cool out now! surprise, surprise!).
I am still facing the zoom responsivness issue:

… I just double checked it the zoom responsivness. I have a very smooth and quick response on a machine with an old GTS 450 but very slow zoom reaction on a new Quadro P2000 (Dynamic Streaming) but rotation is fine!

The zoom responsivness is in shaded mode (little less in rendered) but both with the mouse wheel. Ctrl+rmb works quite well. In general it feels also in rotation that there is some kind of latency which is definitly disturbing while zooming.

Could you please let me know how if there is any fix or recommended setting to make it work.

Best
Tom


(Pascal Golay) #6

Hi Tom - this is a shot in the dark but I’ve heard of several quite different ‘weird’ behaviors that appear to be due to ‘gpu tessellation’ in Options > View > OpenGL page. Normally you’d want that checked but just as a test, uncheck and see if anything changes.

-Pascal


#7

Hi Pascal,

thanks for the fast reply. But I tried this before. Actually the framerate is lower without gpu tessellation and the problem with the jurky zoom and rotation is not getting any better!

Any other suggestions?
Drivers are updated to the latest release…

Best
Tom


(Pascal Golay) #8

Hi Tom - I do not have any great ideas - can you please run SystemInfo in Rhino (6) and paste the results here? Also, what monitors do you have hooked up?

-Pascal


#9

Hi Pascal,

the monitor is a Samsung S24E650BW 24" (1920x1200px).
Here is the SystemInfo:

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @ c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro P2000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Best,
Tom


#10

Hello, any news about this topic?


(David Eränen) #11

Hi @TomWue,

So do I understand you correctly that this happens in Shaded mode also? Are your display settings set to their defaults?

Does it get fixed if you disable “Auto adjust camera target after Pan and Zoom”? (You can find it in Rhino Options -> View).

-David


#12

Hi David,

I just found time to test again after I set up the machine completely new - out of other reasons - without any change for the view problem!
Yes, the shaded view is used with default settings and the “Auto adjust camera target after Pan and Zoom” switched of is unfortunetly not solving the case!

Best
Tom


#16

I have the installer version 6.1.18037.13441, 06.02.2018.
What is 6.2 SRC and where can I find it?


(Wim Dekeyser) #17

Service Releases are accessible as “Candidates” and there can be several candidates before a SR is final (SR2 RCx, or shorter, SRC).

You can get access to them by setting your Rhino Options > Updates and Statistics > Update frequency: to Service Release Candidate.


#18

same issue here. zoom, pan, orbit is laggy if the entire model is not visible in viewport. Redrawing is slow


#19

Hi Wim,

Thanks I found the update and tried 6.2 SRC. Unfortunately there is no change!
How can it be, that a very old GTS 450 performs so much better than a P2000? What has changed in the geometry handling?

Tom


#20

Is this topic still right under Serengeti and with the a title of another solved problem?


(Steve Baer) #21

We’ve strayed pretty far off of the original topic of points getting biased through other geometry. I would split this into a different thread, but the conversations have gotten pretty intermingled. I’ll see what I can do.


(Steve Baer) #22

The geometry handling for display is entirely different in V6 than in V5. Since the difference is between two cards, the most likely problem is something that we are doing that your P2000 driver doesn’t like. Are there any driver settings that you may have tweaked on the P2000?


#23

No, I haven’t changed any specific setting except the dynamic streaming!