V6 Goal: Display Performance



Yes, I use a GTX780 here. The bike model is from 12s down to 2s, so it’s approx. 6 times faster now. And working with heavy models is like working with light models. It’s so great, since my model complexity is extremely grown over the last years. I’m happy.

For further improvements - I tested my worst model and it works better too. I see a working dynamic switch to wireframe mode. That’s fine, I missed it at Rhino 5. Only the time for switching between both modes is approx. 1.5s and could be faster. Maybe it can be optimized. Interesting is that my GTX780 is used at max 37%. (It’s a very heavy model. It’s not the typical complexity of my daily use.)

(Steve Baer) #284

Yep, when this works it blows away the old display speed. I’m still seeing problems with AMD and am setting up a test computer with an AMD card to see if there is anything we can figure out that we are doing wrong on that hardware.

Is your “worst” model composed of more than just polysurfaces and extrusions? I haven’t implemented tessellation on curves yet and blocks still need some love.

New V6 Display Faster: GPU Tessellation
(Steve Baer) #285

Here ya go. Please see this post


It’s a detailed train model, each wagon from a separate linked block file.

Slow Display

Thank you Steve… rushing my breakfast to get to the office to try it out !

stevebaer mcneel@discoursemail.com schrieb am Do., 4. Mai 2017, 06:51:



I tried with 10 of the bicycles, speed is as lightning.
Very very cool.

But I found a problem:
The isocurve settings don’t work anymore.


Slow Display

That one is reported here: :wink:

Rhino WIP: New V6 Display Engine

Thank you Wim, I didn’t see.

I now tried with polygon models.
Impressive performance.


Hi, the display performance with WIP used to be faster than 5.0 on my laptop but now this is not the case.

I tried the GPU tesselation, but for shaded with edges it makes no difference.
(nvidia settings are on max preformance etc.)

Laptop specs:
Windows 10
16 gb

NVIDIA Corporation
Quadro K1100M/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 377.35
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Anything I can do?


(Steve Baer) #292

Can you share the model you are using for testing?



There is something that I have been noticing for a while in V6 WIP display: after each view change (zoom, RMB-rotate), Rhino pauses for 0.5-1s (longer in shaded modes), before it gets responsive again. This is in more complex models, a simple models work fine. This is not dependent on AA, Shadows, GPU Tesselation (tried a lot of combinations) - this is not a new problem, before it was not bothering so much since I didn’t try to do real work in V6. Now is makes is really difficult, this micro-pause after each view change. The speeds within the move sequence before releasing RMB are much faster and nice now, but the lag between the moves is killing all the joy. V5 works fine here with zero-delays. Wondering if anyone else is seeing similar thing. Updated the drivers today, still the same:

NVIDIA Corporation
GeForce GTX 980 Ti/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 382.05
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version:

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB


Hi @Jarek,

i see this too using (6.0.17135.12071, 15.05.2017) when i have a large mesh in the file and try to do anything like drawing a line or when asked to pick a point in any prompts.

It seems to be related to snapping in my case, if i disable OSNAPS it goes away. The delays are slightly longer here, approx. 1-2s but this might be my old systems fault. It does not happen in V5, though. ATM, i cannot use the WIP at all because of this.

ATI Technologies Inc.
AMD Radeon R9 200 / HD 7900 Series
OpenGL version: 4.5.13469 Compatibility Profile Context 21.19.519.2
Render version: 4.5
Shading Language: 4.50
Driver Date: 2-10-2017
Driver Version: 21.19.519.2

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB



Hi Clement,

the model I am testing it with has no meshes, just surf/polysurf, and enable/disable OSnaps does not make any difference, so probably a different issue. Thanks!


(Steve Baer) #296

I haven’t seen this. If you have some case that you can repeat, I sure would like to try it out on my computer.


@stevebaer, 100% repeatable over here using (6.0.17139.2571, 19.05.2017).

Test Data, download this rhino scene, then import this obj file using the import option “Max obj Y to Rhino Z”.

Once the obj import is done, enable the OSNAPS: End, Near, Point, Mid, Cen, Int and try to draw a line or a point. I’ve found that any prompt asking for a point causes a halt of at least one second, sometimes 2-3 seconds while an hourglass is displayed. Navigation using RMB or Zoom using the mouse wheel during the prompts get noticably interrupted over here. If i diable OSNAPS, everything is running fine.

Display Mode is Shaded, using default settings. I can make a video, but the hourglass is not recorded.


(Steve Baer) #298

I think I’m repeating this in shaded mode. You don’t see this in wireframe correct?

@jeff or @mikko, do you have an idea of where this bottleneck may be? It seems like the osnap feedback is getting really slow in shaded mode for he above model, but not in wireframe.


Hi @stevebaer, it super fast in Wireframe. I guess i’ve found why its slowing down. If you enable “Snap to occluded objects” in Modeling aids, its gone. So there must be some kind of occlusion test causing these freezes.



Hi @steve I just updated Holomark to run under V6 and your improvements are massive in wireframe and shaded.
I made a “renderSpeed” mode with no isocurves or edges shown or any fancy stuff, but it is still “slow” compared to shaded and I noticed that using “render material” is slowing it down a lot. 8 units vs 128 (gpu lighting and advanced textures are off) Note that if I use a custom material with rendered color (this eliminates transparency and bump maps) then speed is as fast as with shaded mode.

Holomark 2 R6 v0,01

Total Score: 94296
Total Runtime: 687.63 sec

GPU scores: 83300
GPU_01 - 58.40 fps - Cube 4 tests
GPU_02 - 26.80 fps - UDT Shape
GPU_03 - 59.90 fps - Wireframe
GPU_04 - 59.90 fps - Shaded
GPU_05 - 59.20 fps - Rendered
GPU_06 - 21.60 fps - Block Rendered
GPU_07 - 544 units Nurbs @ 5 fps in Wireframe
GPU_08 - 128 units Nurbs @ 5 fps in Shaded
GPU_09 - 8 units Nurbs @ 5 fps in RenderSpeed
GPU_10 - 60.20 fps - RenderMesh Render
GPU_11 - 61.00 fps - RenderMesh RenderSpeed
GPU_12 - 59.90 fps - JoinedMesh Render
GPU_13 - 59.90 fps - JoinedMesh RenderSpeed
GPU_14 - 52 units mesh @ 15 fps in Shaded
GPU_15 - 84 units mesh @ 15 fps in Render
GPU_16 - 303 units mesh @ 15 fps in RenderSpeed
GPU_17 - 60.20 fps - mesh in Rendered Studio
GPU_18 - 5.50 fps - Nurbs in Rendered Studio
GPU_19 - 11.30 fps - Block Illustration
GPU_20 - 43.90 fps - 2D single
GPU_21 - 4.70 fps - 2D massive (20x)

CPU scores: 10996
CPU_01 - 12.07 sec - Booleans and Contours
CPU_02 - 2.25 sec - Twist and Taper (UDT)
CPU_03 - 6.51 sec - Meshing Mini
CPU_04 - 0.04 sec - Extract Render Mesh
CPU_05 - 0.47 sec - Join Render Mesh
CPU_06 - 17.02 sec - Reduce Mesh
CPU_07 - 1.66 sec - Calculating Technical display
CPU_08 - 5.45 sec - Making Silhouettes

System manufacturer
System Product Name

NVIDIA GeForce GTX 970 - 4095.0 MB

Intel® Core™ i7 CPU 950 @ 3.07GHz
NumberOfCores: 4 NumberOfLogicalProcessors: 8
MaxClockSpeed: 3.07 GHz

TotalPhysicalMemory: 24.0 GB

Microsoft Windows 10 Pro

  • None - 64-biters

Rhino 6 sr 0 64 bit

(Steve Baer) #301

An awful lot of scores in there right at 60 FPS. You probably have V-Sync turned on.

Is there any way to relate these scores to V5? I’m mostly interested to make sure times have improved over V5 instead of over previous builds of V6.


You are both right and wrong at the same time:
I thought this was a new intelligent feature of Rhino to only calculate what was needed, to save the planet (and laptop power) So I just checked on the other computer (the one with an 1070 gtx) and it too had it at default: “Let the software decide” and just checked both Rhino listed and they had it at “OFF”, so it should not be active. So I did a quick test in v6 with a cube in wireframe and testmaxspeed took 1.66 seconds (60fps) Then I sat the default setting to “OFF” as well and then it spins like in v5 (0.11 sec)

I’ll run comparable tests in V5 and V6 on that machine now.