V6 Goal: Display Performance



I am seeing some really odd behaviour… On both machines check out the ghost shadows:
They are from the file I worked on LAST time the computer was ON, and BEFORE I upgraded to the latest V6… seems very strange.
On the other machine it was part of a picture frame that was visible. Can it be the file thumbnail?

As you can see Blocks are not drawing transparency correctly nor is it drawing decals either: (Image of exploded block)

(Steve Baer) #304

I think both of these issues will be fixed in tomorrow’s WIP. I worked on transparent blocks and I think @jeff fixed the other issue


BTW: If I make a block of the entire Mini then testmaxspeed in that scene goes from 3.9 sec to 18.7 sec. So still some room for improvements in rendered mode.

(Steve Baer) #306

That may be related to the transparency bug in block display I worked on this week. Hopefully tomorrow’s WIP will perform better in this area


I’ll test tomorrow!

Here isthe data from V5 vs V6.
The test is using blocks of the car for a lot of the tests.


Hi Steve,

I am uploading a sample file for you via McNeel upload site. It happens with all more complex files over here (view change display delay). What I discovered today is that as long as any object is selected, the delay does not happen and all works fine. Hope that helps to pinpoint the problem. Thanks!


(Steve Baer) #309

Did you test with the WIP that was released in the last hour?


Steve - Yes I just did before sending the file.


Hi Steve,
Transparency is fixed, but decals on objects in blocks are not showing yet. Also the odd shadow artefact was still there. But when I copy paste the object in to a new file then they are gone… odd. Must be some old temp settings in the file of some sort…


Hi Guys,

Just reporting that on heavy nurbs architecture models more than 300Mb in size, the display performance on the last WIP is more than 10 times better than in RH5 last SR (12sec vs 0.98sec using ‘Testmaxspeed’ command)

Thanks for the amazing work. :+1:


Hi all,

I just run Holomark and this are my results:


Holomark 2 v2,2,03

Total Score: 60637
Total Runtime: 318.44 sec

GPU scores: 45840
GPU_01 - 816.30 fps - Cube 4 tests
GPU_02 - 42.00 fps - UDT Shape
GPU_03 - 85.50 fps - Wireframe
GPU_04 - 41.20 fps - Shaded
GPU_05 - 30.70 fps - Rendered
GPU_06 - 28.90 fps - Block Rendered
GPU_07 - 18 units Nurbs @ 5 fps in Wireframe
GPU_08 - 11 units Nurbs @ 5 fps in Shaded
GPU_09 - 36 units Nurbs @ 5 fps in RenderSpeed
GPU_10 - 103.10 fps - RenderMesh Render
GPU_11 - 454.50 fps - RenderMesh RenderSpeed
GPU_12 - 137.00 fps - JoinedMesh Render
GPU_13 - 909.10 fps - JoinedMesh RenderSpeed
GPU_14 - 53 units mesh @ 15 fps in Shaded
GPU_15 - 10 units mesh @ 15 fps in Render
GPU_16 - 475 units mesh @ 15 fps in RenderSpeed
GPU_17 - 92.60 fps - mesh in Rendered Studio
GPU_18 - 9.90 fps - Nurbs in Rendered Studio
GPU_19 - 22.80 fps - Block Illustration
GPU_20 - 73.00 fps - 2D single
GPU_21 - 11.70 fps - 2D massive (20x)

CPU scores: 14797
CPU_01 - 9.58 sec - Booleans and Contours
CPU_02 - 1.35 sec - Twist and Taper (UDT)
CPU_03 - 4.11 sec - Meshing Mini
CPU_04 - 0.03 sec - Extract Render Mesh
CPU_05 - 0.04 sec - Join Render Mesh
CPU_06 - 13.90 sec - Reduce Mesh
CPU_07 - 1.47 sec - Calculating Technical display
CPU_08 - 3.31 sec - Making Silhouettes

Dell Inc.
Precision Tower 5810

NVIDIA Quadro K5200 - 4095.0 MB

Intel® Xeon® CPU E5-1650 v3 @ 3.50GHz
NumberOfCores: 6 NumberOfLogicalProcessors: 6
MaxClockSpeed: 3.5 GHz

TotalPhysicalMemory: 64.0 GB

Microsoft Windows 7 Professional

  • Service Pack 1 - 64-bit

@Holo is there any chance to get the RH6 plugin version?


Interesting is the current display is several times faster than at v5, that is fantastic (!!!), but the GPU and CPU are still not full used (GTX780 <50%, CPU Dual Xeon 2%). So, it looks like the display speed is not so much dependent from the hardware. Maybe this can be solved so that the full hardware power can be used.


@stevebaer - The ‘pause’ after each shaded/render view change is still there in the latest WIP (unless an object is selected - then works fine) - I thought it might have been the same issue that you fixed with Enable/Disable redraw scripted method but no, must be something else. Hope the ‘selected object’ fixing the problem might give you some clues…


Sorry for the late respons…

Here’s a screen capture of Rhino 5 64 bit and Rhino Wip. In Rhino 5 the model rotates/zooms very fast. There is no difference if the model is zoomed out or in.

Rhino Wip is only fast when the model is zoomed out pretty far, when zoomed in the display is choppy/shocking (I don’t know the correct word).

I will send the model for testing. But the difference is already noticeable with a simple cube.


(Steve Baer) #317

Based on your video it looks like you are using a SpaceMouse. If you completely unplug the SpaceMouse and restart Rhino 6, do you still see a lag? I’m trying to pinpoint the cause.


Hi steve, that did not work either. It might has something to do with windows 10? When I had win7, the Wip version was faster than the 5 version…

(Steve Baer) #319

Did you upgrade a computer from Win 7 to 10? If so, make absolutely sure to check on your display drivers and see if they are the latest.

Let’s try one more thing to make absolutely sure the SpaceMouse is not interfering. Go to the plug-in manager and disable the space mouse plug-in and restart Rhino. Does this have any effect on performance?


Nope! Still the same

(Menno Deij - van Rijswijk) #322


This seems related:

(Steve Baer) #323

A post was split to a new topic: Steve Baer