16 may display ghost in the machine


#1

Here’s a screen shot of the the same stuff in V5 & V6, shaded display.

You can see there are problems with the shading of the tyres in V6, although the hubs are fine.
This stuff is extracted from a much larger file, that mostly displays ok in V6, but there are other examples that are similar.
The tyres are open polysurfaces, whereas the hubs are closed. Capping the tyres makes them display ok.

As i say, this is shaded display. Switching to rendered display locks V6 and the whole computer, as it has done over the last months.
At least here in this current wip I appear to be able to work in shaded, ghosted or wireframe modes, which is great for copy paste from V5 to use, for example, the new make2D command.

I continue to download the WIP’s as they come out, but I have accepted that realistically V6 is never going to work properly on this older computer - should i continue to post about it or just leave it be, and fade away in a ghost like fashion into the faded rhino netherworld of lost and past wips, newsgroups etc…?

cheers
rabbit


(Steve Baer) #2

Can you share the model? This may not be isolated to your computer.

I have a cabinet full of old computers that I use to try and repeat problems like you are seeing. If you are crashing while entering rendered mode, there is most likely some little piece of code that your graphics driver is getting hung up on while attempting to compile a shader. We’ve run into these before and have always found a workaround once we figure out exactly what is wrong (with one exception, but that is an old mac).

Believe it or not, our primary display goal for V6 has been stability. A ton of effort has gone in to make V6 run smoothly on as many drivers as possible. I’m out of the office next week, but after that I’ll pull out the old computers and see if I can repeat this crash.


#3

thanks Steve

here is the model, & also the system info…

cheers
rabbit

Rhino 6 SR0 2017-5-16 (Rhino WIP, 6.0.17136.10381, Git hash:master @ 132f70880fccbff1340d813f10addb24f9d42fef)

Windows 7 SP1 (Physical RAM: 7.9Gb)

ATI Mobility Radeon HD 4650 (OpenGL ver:3.3.11672 Compatibility Profile Context)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: ATI Technologies Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 11-16-2012
Driver Version: 8.970.100.7000
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a

may_16_v6wip_test_rabbit.3dm (2.9 MB)


(Steve Baer) #4

Thanks for not giving up on us yet :slight_smile: It does look like the issue is specific to your GPU/driver. Here is what I’m seeing with my development computer. I’ll try this out on some other computers when I get a chance


(Pascal Golay) #5

@rabbit - this looks OK here, but I see that the tires are flipped ‘inward’ - do they display correctly if you use Flip on them?

-Pascal


#6

Hi Pascal

Yes, “flip” makes them display correctly - but rhino should sort this out itself ideally…?

This current WIP is actually a bit of an improvement here re display:

I can display objects correctly in all but artic,and render modes - even raytraced.
The render display, while it still doesnt display correctly, no longer crashes the computer.
Referring to the test file of the two wheels, Artic, render and raytraced all start out the same: a white background, with the dashed lines displayed, and “holes” where the wheels are - ie, if i rotate the display, I can see where the wheels are as they obscure the dashed lines.
The raytraced mode “thinks” for a second or two, then builds the picture.
The render mode initially does in fact render the hub only closest to the viewer, but as soon as the display is rotated it vanishes, and never comes back.

So its progress for sure, especially since otherwise the WIP seems to work well, and so far appears stable…

cheers
rabbit