Poor Display Performance on One Computer


The WIP display performance particularly in shaded mode is extremely slow compared to v5. I’m comparing the same model in v5 vs latest WIP.
Any ideas what the problem is and if I can resolve this?



HI Brian

Any ideas why spinning around the viewport is so slow? When I compare the same data in v5, it’s instant, but in v6, it’s very laggy - especially in shaded mode.


There is still a lot of optimization work that needs to be done. I can’t say exactly what the problem is on your system without seeing an example file. Do you have one you could share?

Post a file as Steve mentioned or send it in to tech@mcneel.com . Also run the SystemInfo command and give us that text too.



I’ve emailed you the files.


I just installed the latest WIP update and it still has the same issue…

Thanks @sach I replied with some ideas to try… the driver for your GPU is not being seen by v6. We can continue the discussion on tech.

Hi @BrianJ & @Vanessa

Any updates on this? WIP is still extremely laggy in the shaded & rendered modes… WIP has been updated a couple of times since of our last contact on this and it’s still the same…

If it’s any help, I’ve recently tried using a second display with this DELL Precision M3800, and it’s even worse when viewed on the second monitor…


At the moment I don’t have any new info on when display optimization work in v6 may be done to possibly help with the display speed on your system. @jeff @stevebaer Do either of you have a YT item we can post here to help track the issue?

@BrianJ please create a YT issue and assign it to me.

done… https://mcneel.myjetbrains.com/youtrack/issue/RH-37897

I looked at the file you sent and it is just 6 planes. I did get a missing image warning dialog so maybe the planes had some sort of picture applied. Is Rhino slow and laggy when you just draw a single plane and go into shaded mode?

Hi Steve.

I will try with a single plane.

The file sent you is fine in version 5. It’s instant in shaded mode.


Sach Chauhan

HI @stevebaer @BrianJ

I’ve just installed WIP on a client’s machine - Dell Precision M6800, and the speed seems normal now… I haven’t tested this latest build on my own machine on which it was very slow, but has this issue been resolved?

Attached is the system info for this machine.system info.txt (1.3 KB)


It is hard to tell. We are always finding and fixing bugs in the display code, but I could never isolate what was causing problems on your specific system so I don’t know if the fixes we made recently will make a difference for your system.

Hi @BrianJ

I’ve sent you an inbox about this. Any ideas on other settings as I still am having this issue with my M3800 although the machine I was using last week was fine!


@Trav, can you help Sach with the nVidia settings that you mentioned yesterday that may be causing display problems?


If you’re having some frame lag and have the geforce experience installed you may want to check to see if the shadow play share settings are enabled and disable them. There have been more and more reports of driver updates toggling this on.

Here’s a link to how to check the setting and disable it if needed.

Hi @sach I don’t see a private message from you here or an email to my mcneel account, can you send it again if it was a 3dm file to test? I don’t have this specific GPU but I just tested the Geforce Experience Shadow play (now called Share) and don’t see any adverse effect in the v6 WIP. I suspect this is not an issue with all cards and driver combinations.

Pretty sure this is specific to Sach’s setup since he mentioned things worked just fine on another computer. Another thing to try is to adjust the vsync setting in the driver. I’ve seen that cause problems on other systems.

Please let us know if any of these driver tweaks make a difference.