V6 dxf import broken


(Willem Derks) #1

Hi,

Text import from dxf seems broken in V6:

dxf exported from V5:
text_in_border.dxf (162.8 KB)

HTH -Willem


(Miled Rizk) #2

I tried to import and it worked fine,

i then tried to reproduce the problem, and the only way i managed to mess things up is when

The system Model Unit and the Model Units parameter that you see in the import dialog don’t match up.

For the system Model Unit, you need to go to File menu, properties, Document Properties, Units, Model


(Pascal Golay) #3

Hi Willem -
Yep, I see this - the text size is not scaled but the border is.
https://mcneel.myjetbrains.com/youtrack/issue/RH-43932

thanks,
-Pascal


(Willem Derks) #4

Hi Pascal, @Miled_Rizk

I don’t understand what you are referring to.
Imported in V5 and V6 the same dxf displays the text at another location.
I do not see any scaling, I see a shift upward.

Thanks -Willem


#5

Would this have anything to do with the text justification settings in V6 as compared to V5? --Mitch


(Willem Derks) #6

Indeed,

The justification of the imported text is both LEFT BOTTOM
Apparently V6 does not parse the text in the dxf correct.

-Willem


#7

Interesting… If I Open your file in both V5 and V6 here, I get the text inside the border, but with a slight difference - V5 is higher in the box than V6:

V5 (shows left/bottom justifiied):


image

V6 (also shows bottom/left justified):


image

If I copy from V6 over to V5, I get this:

If I copy from V5 to V6, I get this:


Because, V6 has applied the default style (including text height) to the incoming text…
image


(Pascal Golay) #8

Hi All- What I found was that if I import but set different units on the import than are in the Rhino file, the text comes out the wrong size - it seems to keep the numbers the same for its height but in the current model units. I see this is a different thing than what Willem is reporting… which I do not see here - quite. I do see that the text is not centered in the border - like what Mitch shows.

-Pascal


(Willem Derks) #9

Hi Pascal,

I have everything in mm upon export and import
Maybe I’m doing something wrong or omit relevant info.
Let me know if there is anything else you guys need to track this issue down.

_Willem


(Pascal Golay) #10

Hi Willem - Here’s what the text shows in Properties, here-

image

Is that what you see?

-Pascal


(Willem Derks) #11

This:

EDIT FWIW

my default style in the doc


(Pascal Golay) #12

Yeah, it all looks the same, settings wise. I’ll reinstall 6.0, I am a few builds ahead…

@Willem - in 6.0 I see what you see…
And it’s better but not quite right in the latest in-house build.

-Pascal


(Willem Derks) #13

Another thing to mention:

The laptop came installed with WIN10 in dutch. I switched to English when finalizing the setup.
However, maybe there are some trailing settings with localization ( eg decimal seperators) that act up?

-Willem