Interesting DXF import experience


#1

This is the first time I’ve seen this one…

Had a file arrive for laser cutting here that when imported into Rhino V5, turned up empty. However, looking at the file size, it definitely had things in it. It imported into Type3 (with a lot of difficulty). I at first thought it was like a DXF 2018 - too new for V5 to open - so I thought I’d open it in V6… that’s where the fun started.

First, Importing into V5 produces nothing. The command line does say 2960 block definition objects read, but try and find them…

Next Opening the file in V5 produces a layout page which Import didn’t. Aha. But there is nothing I can see on that page…

Next Importing the file into V6 produces nothing as well… Not even any messages about block objects like in V5.

Finally, Opening the file in V6 produces something. There is a layout page, and huzzah, I can see some objects. It’s one big block. I can explode that, but I need to get these objects into model space for cutting… Try the _ChangeSpace command. It wants me to pick a detail to reference - but there isn’t any! :confused:

Hmm, a layout page on which there are objects, but no details… Finally, I thought, what if I just create a new detail which covers the whole page…? And it worked! When I first did the ChangeSpace, the objects came into model space at a random scale. That’s when I realized why one has to pick a detail for reference, it’s in order to set the scale conversion factor. So I went back and made the detail scale 1:1, and then the ChangeSpace’d objects were the correct size. Phew.

Here’s the file if you want to play with it. :smile:

Export.dxf (2.4 MB)

–Mitch


(Wim Dekeyser) #2

FWIW, you can always just Ctrl X in the layout and Ctrl V in modeling space without having to deal with details.


#3

I thought I’d tried that first and it didn’t work… maybe I got it wrong though.


#4

Hi Mitch

Here is a way which works, select from within the block manager, the block on the layout page can then be copy and pasted into modelspace and scaled accordingly.