Frozen Viewport - Rhino 5

I just had issue with Frozen viewports - using GeeForce GTX 980m. Rhino has been running on this computer for years but suddenly all viewports freezed - or did not update until new tab was selected (Standard, Cplanes, Set view etc.). When selecting new tab viewport updated.

The solution was to de-select accellerated hardware modes (Tools->options->OpenGL

Hi Henrik - could you run the Rhino SystemInfo command and post the result here?

Hi Wim,
I am using version 5 and the command “systeminfo” is not a know command in this version.

Hi Henrik -
I’ve moved this to a new thread as the “Serengeti” category is for issues with WIP versions - Rhino 7 at this point.

Please post a screenshot of your Rhino Options > View > OpenGL page.

With this setting I have no problems. But if I use accelerated hardware modes my viewports will not update.

Well turn the hardware modes back on and repost that shot so we can see your driver information. Something needing to be updated is the usual problem.

Thanks for that information, Henrik!
This portion…
… tells us that MS Windows is not finding a GPU on your system and lets Windows do all the screen drawing. You will have to find the most up-to-date driver for your card and your OS and install that.

I just checked V5–why I still have it I don’t know–and that’s what it shows if you turn off hardware acceleration.

Thanks for checking that, Jim!
@henrik1, could you post that screenshot with hardware acceleration turned on please?

Sure - here is the screen dump with hardware accelleration turned back on:

The strange thing is that the system has been working for years - probably by some update I got this problem. I guess it could be either due to an update or potentially a hardware problem on my graphics card ?

I think this thread has taken a wrong turn. It’s all well and good to understand what hardware and drivers are involved but I think the key question is implied by this:

In other words the main question is “what changed”?

Many others on the forum have reported problems due to Windows updates messing with their drivers.

@henrik1: What version of Windows are you using and has it been recently updated?

Edit: I was typing this while you posted your preceding message.

@AIW - running windows 10 with all recent updates. Driver for graphic card is also updated recently. I am not really sure what changed before this problem occurred. My intension with my post was mainly to provide a solution for getting rid of freezed viewports.

Best regards

Hi Henrik -

The thing is, that’s not really a solution. It’s a quick-fix that will degrade performance. If you are fine with that, then, no problem - case closed.

We’ve seen several times that a Windows update will mess up display drivers. You won’t notice unless you use an application that heavily relies on updated OpenGL functions. A simple driver update won’t necessarily solve the issue and one has to completely uninstall all drivers for all GPUs and then do a clean install of the most recent drivers.