V-Ray load error - Dependent dll out of date


I just installed V-Ray 6 hotfix 2 from Chaos, installation is ok, but then I get a error message when Rhino starts (cf. image below).

I already followed the advices and suggestions from this topic, but no luck so far : V-ray for rhino won't start
Any clue ?

Best regards,

What do the details say? Is your Rhino up to date as well?

Details doesn’t say much :

I’m running Rhino 7 SR27 (2023-02-01), and updated all my Rhino installations (6 / 7 / 8 WIP) with the latest installers on rhino3d.com

@Nikolay do you have an idea what might be causing this?

Most probably the visual C++ redistributable, however we did not updated the buildtime version.
download here https://aka.ms/vs/17/release/vc_redist.x64.exe

It might be duet to a dependency of the V-Ray core.

Mind that the message “Dependent DLL is out of date” is coming from Rhino, not V-Ray, and it most probably gets it from LoadLibraryW(), which is notoriously difficult to debug.
I usually use gflags to debug these soft of things.

Just reinstalled the vc_redist.x64 and reboot, still the same error at loading.
Here is my SystemInfo output, if it can help :

Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13001, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Commercial, build 2023-02-01
License details: Cloud Zoo

Windows 10 (10.0.14393 SR0.0) or greater (Physical RAM: 24Gb)

Computer platform: LAPTOP  - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
  Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.12
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
        - Secondary monitor attached to adapter port #1

Secondary graphics devices.
  Microsoft Basic Display Adapter (AMD) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).
    > Integrated accelerated graphics device (shares primary device ports)
        - This device is not being used

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 9-13-2021
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
  C:\Program Files\Orca3D V2\\Orca3D.rhp	"Orca3D"

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp	"Grasshopper"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.27.23032.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 7\Plug-ins\Calc.rhp	"Calc"

try disabling extensions that do not ship with Rhino. I see that it is only Orca3D, so give it a quick try.

It happened before with some weird software, installing and registering globally DLLs that are incompatible with V-Ray.

If that doesn’t fix it, are you OK contacting Chaos support team ? They can arrange a remove session, and I can join to check what’s going on.

Same error when starting with Orca disabled.
Ok to check with Chaos support team, I created a ticket : #88676

Do you by chance have installed software called ChiTuBox ?

shooting in the dark, really, but that was causing problems before

Nope, not this one.
Long time ago I had MakerBot Desktop, but uninstall from a while now.

Ok, the support guys will take care

Hello, Chaos support had a look by remote session today, but didn’t find out.
So, they advice to make a clean install of Rhino without any additional plugins, which I did, but I still get the same “dependent dll out of date” error on start, even with this new fresh install…

There was a misunderstanding. The idea was I to look in and debug ot site. Can I have another session with your system ?
I’ll talk to then tomorrow

Hello Nikolay, I updated the teamviewer credentials on the ticket #88676

The problem seems to originate in the Windows system libraries.
The OS is Windows 10 LTSB 2016, and the SetThreadDescription which VRayForRhino.rhp calls is not directly exposed from kernel32.dll, but only thru GetProcAddress-ing kernelbase.dll, which we don’t do.

According to MSDN (SetThreadDescription function (processthreadsapi.h) - Win32 apps | Microsoft Learn)
the problem is fixed in later versions of Windows

I guess updating your Windows to something more contemporary will fix the issue.

The version after 1607 is 1703, but I guess that is not available with Windows Update and it will download the latest - 2604 (22H2).

The support guy will write you with more details.

Hello Nikolay,
I was thinking about the same cause, good to know and thanks for your investigation.
I will see how I can simply upgrade my Windows 10 then.
Thanks again for your help and feedback.