V-ray for rhino won't start

hello everyone,
i’m having a rhino issue i cannot undertand by myself.
i installed v-ray 2.0 for rhino 5.0 with its easy setup, but when i launch rhino, the plugin won’t start, i can’t see any way to launch the renderer. no issues, no messages, no problems at startup. simply it does not work.
i tried to load the plugin manually but it says “unable to load vrayforrhino.rhp plugin: inizialization failed”. any ideas?
thanks in advance.

Just to be sure: did you set your default render engine to V-Ray? You won’t see any loading until the plugin is actually needed.
You should see a new entry (V-Ray) in the “Render”->“Current Renderer” menu.

yes, that was one of the first things i tried to do but unfortunatelly no other renderer than the rhino one is listed.

Did you notice any errors during the installation process?

The V-Ray plugin consist of several layers that may fail. There’s the .rhp plugin that may not work. Check if you had previous versions of V-Ray that are completely uninstalled so there are no plugin conflicts.

The installer should have taken care of it but just to make sure, check that all .dlls and .rhp in the V-Ray folder are unblocked.

V-Ray makes extensive use of Python. I’m not sure if this is required to load the .rhp in the first place. There might be a conflicting Python installation or the installation of the required code may have failed. Try to check if python is working in Rhino.

V-Ray will load without the dongle and only check for a valid license once it actually renders, but just to make sure, check if the WiBu key drivers are up and running.

V-Ray should generate a debug log in the application folder called vfr_stderr.txt. Check what that says.

Did you try a reinstall? Some times it helps.

hi halo,
no errors during the install process (ubviously i tried a full reinstall)
as i can see, no other previous installations are present
wibu key drivers are up and running even if the the dongle is on the license server (i tried to force with success the remote dongle check in the widu util)
i’ll try to start checking the installation log you suggest first.

Hi dobricchi

I have the same problem with v-ray, and I´m not successful in resolving the problem.
I reinstalled several times v-ray, and it didn’t work. Although the first time I run rhinoceros, v-ray was recognized, but when i closed and ran again, v-ray disappeared and it didn’t work.

I´m very lost because I´m not able to solve the problem and it doesn´t work.

Any suggestion?



I’m having a similar problem with Rhino 5 SR11 and Vray 2.0. I get an error while opening rhino stating that VrayForRhino.rhp can’t load: dependent dll out of date.
I’ve uninstalled rhino and vray, deleted all of the leftover folders and files, reinstalled it several times and still get the error.

The only thing I can think of is Iron Python plug-in, which I installed previously and even after several reinstalations it still comes up.

Any ideas?


Have you tried removing this registry value:

Hello Matt,

Thanks for the quick reply. I’ve searched for that key in the registry and didn’t find it.
I also tried today to remove rhino 5 32bit and 64bit, deleted all remaining folders i could find after unistalling (in both programs directories, common files, program data, and users). Ran CCleaner to delete all leftover registry keys. Reinstalled Rhino, apparently missed one plugin (Jamparc was already installed on rhino x64), and tried to installed again Vray and nothing. Same error again!

I have no more ideas on how to solve this. I guess there is a wrong version of some dll but can’t find which.

Thanks again.

Filipe, do you have the most recent VRay downloaded?


Hello Pascal,

Yes, I downloaded the latest version from chaosgroup site: sp_20025251.


Hi Filipe, did you check with them (Chaos group) about this? I’m not sure where the problem lies but I’d ask there as well. And, just to be sure, did you uninstall and reinstall Vray as well as Rhino?


Yes, I’ve checked with them. They tried to install vray over a remote session on my computer several times with no success. They are considering bringing in a developer to try to find the issue. In the meantime I tried a complete uninstallation of rhino twice and still nothing.

I’m also not sure where the problem is. I’ve tried everything I can think of.


Hi Filipe - You might check for Windows updates as well…


Thanks for the tip. I’ll try that now.


Do you have any other plugins that use Qt such as the ones mentioned in this post?

After several installation/uninstallation cycles of Rhino, the only plug-in that still comes up after installing Rhino (without my intervention) is Jamparc which is not one of the plug ins mentioned in that post.

I read here: http://www.scan-and-solve.com/page/dll-out-of-date a suggestion of using depends.exe to try to check what is wrong. I did what they sugested with VrayForRhino.rhp and I get a lot of dependency errors. But I’m not sure how to handle the problem. Here is a printscreen of what dependency walker finds.


I’ve installed all the latest windows updates, including one Net Framework update, but it didn’t solve the problem.


The report is completely normal, Dependancy Walker does not have any information about how V-Ray For Rhino loads the needed DLLs. All of those DLLs should be in C:\ProgramData\ASGVIS\VfR564 , C:\ProgramData\ASGVIS\Common\x64\vc10\Python27, C:\Program Files\Rhinoceros 5.0 (64-bit)\System

Another thing you could try is to install the Visual Studio 2010 (x64) Redistributable: https://www.microsoft.com/en-us/download/details.aspx?id=14632

It should be in the installer, but maybe it is failing behind the scenes.