UV Mapping Problem with Brazil Rendering

rhino
brazil
visualarq
unhandled

(Hernan Aparicio) #1

I created a house to try out my new Brazil rendering engine that I just bought (very expensive for me). I applied UV mapping to the walls of the house and in the viewport everything looked correct. However, went I clicked render, the siding on the house was incorrect and I don’t know how to fix it. The viewport still shows the correct siding orientation, it’s just the render that is incorrect. Help!! The siding is supposed to look like the siding in the second picture. Horizontal all the way around. In the render if you look at the front wall the siding is vertical.
Bug%20Example


(Brian James) #2

Hi,

Are you using Rhino 5 or Rhino 6 for Windows? Also, can you include the file in the post here or at least the portion that has the material applied to it. If you are using Rhino 5, please also include the image texture used in the material by clicking ‘save textures’ in the save as dialog or by posting it as well. In Rhino 6, textures should be embedded in the 3dm file by default.


(Hernan Aparicio) #3

I am using Rhino 5 for Windows. Here is the file. House Plans 1 HA.3dm (5.2 MB)

The texture is wood_boards_3.rmtl (272.6 KB)

I don’t think it has to do with the texture, though. I believe it is the UV mapping that is being lost in the rendering


(Brian James) #4

The issue is with how the VisualArq ‘instances’ handle texture mapping and also how Brazil renders texture mapping for block instances. It appears that the instances (parametric walls etc.) only use the mapping set for the texture within the assigned material. Your image textures were not embedded in the rmtl so I made a new Brazil advanced material and added one to illustrate the options you have.

The first is to use WCS box mapping within the image texture in the material like this…


The downside is that the OpenGL preview in Rendered mode won’t display the texture as it is rendered with Brazil so you’ll have to do test preview renders to get the mapping scale correct.

The second option is to use Explode to turn the VA instances into polysurfaces. Then the default of Channel one for the image’s texture mapping will use what is set for those objects in Properties>Texture Mapping. This is also what the OpenGL Rendered display will show making it easier to get the mapping scaled like you want.


I hope this helps. I’m not certain whether VA or Brazil would need to change to correct this. @andy Can you add anything?


(Hernan Aparicio) #5

Hi, thanks Brian

I tried the second option, but when I exploded the walls all the windows and doors disappeared so I will try the first option. When I check my material I do not have the “mapping” tab on my materials window. How can I add this option to my materials tab?