UV Editor not rotating all maps

I’m editing textures on polysurfaces in Rhino (mac) using the UV Editor. A simple 6 sided polygon has a wood grain texture going in the wrong direction. I run the UV Editor command, rotate the meshes and hit apply, but only the Diffuse map changes its UV direction. When the polysurface catches the light in rendered view, it is apparent that the AO, SPEC, NORM, etc. have not synced with the diffuse.

Is this a bug? I don’t feel like Ive encountered this problem before working in the same manner.

System Info:
Rhino 7 SR30 2023-5-10 (Rhino 7, 7.30.23130.11002, Git hash:master @ 92e6bbd255ee28a4168ed9e8d38a590062283b45)
License type: Commercial, build 2023-05-10
License details: Cloud Zoo

Apple macOS Version 12.6.6 (Build 21G646) (Physical RAM: 64Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-US (MacOS default)

AMD Radeon Pro 5500M OpenGL Engine (OpenGL ver:4.1 ATI-4.8.101)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB
Graphics: AMD Radeon Pro 5500M
Displays: Color LCD (198dpi 2x), LG UltraFine (186dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5500M (8 GB)
Color LCD (1344 x 840 @ 59.00Hz)
LG UltraFine (1920 x 1080 @ 60.00Hz)

USB devices
Apple Inc.: USB3.1 Hub
LG Electronics Inc.: USB3.1 Hub
LG Electronics Inc.: LG UltraFine Display Controls
LG Electronics Inc.: LG UltraFine Display Audio
Canon: MP470 series
Apple Inc: USB-C Digital AV Multiport Adapter
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswift_Concurrency.dylib
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftCryptoTokenKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/swift/libswiftCoreAudio.dylib
/usr/lib/swift/libswiftCoreML.dylib
/usr/lib/swift/libswiftCoreMedia.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftVision.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftNetwork.dylib
/usr/lib/swift/libswiftDemangle.dylib
/usr/lib/swift/libswiftFileProvider.dylib
/usr/lib/swift/libswiftIntents.dylib
/usr/lib/swift/libswiftPrivate_BiomePubSub.dylib
/usr/lib/swift/libswiftPrivate_BiomeStreams.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftAVFoundation.dylib
/usr/lib/swift/libswiftCoreMIDI.dylib
/Users/diomira/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/libtbb.dylib
/Users/diomira/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/libtbbmalloc.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino
/Users/diomira/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.4/IntelDenoiser.Mac.rhp “IntelDenoiser.Mac” 1.0.0.0

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.30.23130.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.30.23130.11002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.30.23130.1002

are all the textures using Mapping > Mapping Channel, or might some (those not responding to the uv changes) be set to WCS/OCS?

if they are all using Mapping Channel, then the other possibility should be that there are multiple texture mappings (in object properties > texture mapping)

I agree with JD, the other maps are probably set to WCS which will override the Object Properties > Texture Mapping setting. You should see a message at the top of this section of the Properties panel that says as much and has a link to “change this automatically” which will set all maps in the material applied to be mapping channel 1. Alternately, if you use the Materials panel with the Tree display mode for the previews, you can select multiple maps and edit the mapping channel for them in unison.

Thank you @BrianJ and @jdhill,

Tree Display mode helped tremendously to synchronize multiple map editing. I need to better understand situations where WCS/OCS is useful over Mapping Channels, which may be what is creating other problems in my workflow.

This solution worked to solve the problem above.

1 Like