Unwrap bug


i unwrap a polysrf and everything seems fine unless i rotate the object. If i do this the texture behaves in a strange way as seen on this image.

It’s not the first project where i found this problem: everything works all right til the moment i rotate the object

Any idea? Thanks

p.d. i’m running Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001)

If i open UV editor it seems to be alright

but when i click OK it gets wrong again

I don’t know what happens only I ask me how your both states are looking if you render the view. (Is rendering your goal?)
So far I understand Rhino is using an idealized mapping for display use but for rendering a limited polygon based mapping is used. So, maybe you see the display pipeline switching between idealized projection and polygon mesh UV mode.

Thanks for answering!

Once i apply the UV editor glitches appear as seen on the first image (it was an on going render).
The strangest issue is that the mapping works perfect till the moment i rotate the object for visualization purposes.
In this kind of projects i need to make the renders for product viz but also all the technical for fabrication. I tried to mesh the polysrf but didn’t work .

Hope somebody at McNeel could help

The rendering looks perfect before you turn the object or the viewport preview?

There is a pitfall - also if the mapping looks perfect at the viewport you can get distorted mappings during rendering. So, you never can trust the clean looking mapping of the viewport. Workaround - use a finer display mesh or use a V-Ray mapping like tri-planar (it should follow the turned object if you convert an object to a block).

Here it was discussed.

1 Like

1000 thanks!! (i knew your avatar looked familiar, from Chaosgroup forum!)

My steps are:

  1. Unwrap
  2. UV editor (at this point it’s ok in the viewport and renders ok)
  3. Rotate the object for visualizations (classic photo set with backdrop)
  4. Distorted mapping on viewport + rendering

After reading your links It seems more a limitation of Rhino than a bug.
Tri planar is not and option since i need to control texture mapping because of my clients, we ussually work with wood and stone.

Anyway, thanks a lot!!

Sounds like a bug. Maybe internal a kind of custom mapping object is be used and this isn’t following the visible, rotated object.

I would try a workaround and convert the object to a block first, switch to block edit mode, apply a custom per UV editor and leave the block editor mode. My hope is that the mapping is fixed within the block.

Maybe @nathanletwory can check the issue and tell more. :wink:

1 Like

Hi @12Lab
This is a known issue and we are actively working on improving this in Rhino 8.
It would be great to have your model as a test case - you can use our upload page if you don’t want to share it in public here.

Here is a workaround that sometimes solves this issue:
When your model still renders correctly (before rotating it) run _TestRenderMeshMapping. That command makes the custom mapping primitive match the object render mesh and resets mapping transformations. Then it is less likely that the next rotation will ruin the rendering.

1 Like

Thanks @Micha ! you were right, it worked! block + custom UV. I had no more problems!

Thanks @Jussi_Aaltonen .

I’ll upload the file through the link you told me.

I tried _TestRenderMeshMapping and it got worse:

@Micha technique worked great, at least on this project!