Uploading a texture for a model doesn't work. :(

I’m using Rhino 5.

When I upload a texture image for a UV model, the window processes but doesn’t change. Uploading a model works, but the texture produces no effect - even when hosted externally and piped in with a text input.

However, when I am editing the model and have embedded the mesh, it works when uploaded. But it still doesn’t work when I’m in the editing mode, upload a different model, then upload the texture (the model loads but not the texture).

My setup (I removed the URL plug in):

I am not sure I understand where the problem is exactly. I created a definition in Rhino 5 with a geometry input and an image input, and it seems to work fine, whether i link to external files locally or I upload files from ShapeDiver online. Could you test this file and let me know if you can reproduce your problem? If so, please explain exactly which process does not work as expected.

texturetestrh5.gh (8.6 KB)

Hey Mathieu,

That works - but so does mine, locally. The problem is when it’s uploaded to Shapediver, uploading or adding a texture doesn’t change the 3D viewport on the website.

This happens whether I link to an uploaded file on a public domain or upload the texture directly to Shapediver. Despite what happens in Rhino, Shapediver won’t display the image on the model.

It works for me. Could you:

  1. Upload the model is sent you to your account confirm that it doesn’t work for you and then send me a link to it?
  2. Check the size of the images you are trying to upload? There is a limit oder 4mb per image.3
  3. If the problem persists, tell me if your browser console sends any errors. Which browser/version are you using?
  1. It works when I upload an image to the cube, but when I try to upload my image and my own model, it doesn’t work. I opened the model locally in my own software and it does work when the texture is applied.

  2. Texture size is 1024x1024 @ 174 kb.

  3. No errors, Chrome, latest version AFAIK.

Can you post the mesh and image you are trying to upload to my model and that make it fail so I can test? You can send them in a private message if needed.

Sent via PM!

It seems that the OBJ importer from the ShapeDiver plugin imports your file (created in Meshlab as far as I can see) as an invalid mesh. I opened the file in Rhino 5 and exported it again from Rhino, which fixed the issue. Make sure to use the following export options (I think the issue happens if the “Wrap long lines” option is checked):

Re-exporting your files from Rhino might be tedious if you want to automate the process. The Rhino 7 version of the ShapeDiver plugin should fix the issue out of the box because the plugin will use the native Rhino importers instead. But if you want to stick to Rhino 5 or 6, the workaround above will be necessary.

I’ll give this a shot, thank you! :slight_smile:

Hey Mathieu,

Just tried this again. Still no luck. The model works fine - the texture still doesn’t update.

Can you send me the new OBJ file you re-exported from Rhino so I can check it?