Results for this parameter value cannot be display error or simply upload error

I am getting this error when I try to interact with the “verzinkt” material.


I don’t know if its a matter of the Output size because our account is Pro and not enterprise so we are only allowed to use 20mg.
The other 2 materials worked quite alright. The only difference is that on the Verzinkt material I have 0.85 metalness and on the other 2 I have 0 metalness. Besides that I don’t have any difference.

In this case the file actually uploads: https://app.shapediver.com/m/updated-textures-and-rows-diagonals-3

I am currently trying to upload pretty much the same file, in which I only change 3 names but the file doesn’t upload anymore and I get an error:
"Oops! The server encountered an issue with your model:
Computation of your model failed. Please ask for help on the forum, including the reference shown below in your message.
(Ref: 7dcf8fbb-1403-4811-8ceb-bf3979a2a571)"

What is causing this problem?
Thanks in advance

PS: I check the amount of meshes per Geometry Output and the total number of meshes and it is quite below the limits that you describe on your documentations. If I am wrong in that regard please let me know

I had a look at your model and could identify the problem. It’s a bug on our side, but there is a quick fix you can do which makes sense anyways because it will make your model faster.

The problem is linked to textures. When using textures, there are two types of inputs you can use with the material component:

  • A GrasshopperBitmap object, created with Squid or the Image tools from the ShapeDiver components.
  • An external URL pointing to an image file.

In your definition, in several instances you make the operation of converting a URL into a bitmap object (using ShapeDiverImageInput), and then inputting the bitmap object into the ShapeDiverMaterial component:

In this case, the conversion step is not necessary since you can use the URL directly with the material component. On top of that, removing it will make the definition slightly faster:

Now that doesn’t explain the problem but it will solve it. The problem comes from the fact that multiple bitmap inputs were reused in different output components, which our server gets confused with at the moment. This will be solved in the near future.

1 Like

Thank you Matheu!.
I did try the Bitmap component before but it increase the file size from 156kb to 7000kb, and it didn’t upload anyway.
I wasn’t aware I could simply plug a text into the texture slot because I didn’t saw this option in any of your examples. I think it would be really useful if you add this to one of your blog’s entry on materials.

On the other hand if I would like to input a texture through the API then I could simply input the ShapeDivertextInput then?

We’ll add details about the text option in the documentation, thanks for the feedback.

Yes, you can use the ShapeDiverTextInput to just let your developer send any URL to the material with the API, that is the standard way to get it done.

Thank you again!. The file is now running smoothly

1 Like