Update to 6.19.19... Rendered view behaves substantially different

Hi @jeff
Hope you are the right person to address :slight_smile:

I open well-defined files after the update and notice that rendered view looks completely different. And not to the better…

  • Materials seem to behave different (very reflective although they should not be)
  • Ambient occlusion seems to be off (while Skylight is on. Toogling it does not seem to have any effect)
  • The groundplane is an endless boring grey plane that does not seem to be affected by any objects.

Screenshot of the nice rendered view of the same file before the update:

Screenshot after the update:

Any advise on how to get the nice clean rendered look back much appreciated.

@FrankS Would it be possible to get the file?

Have you tried restoring the display mode to its default settings? At the moment, I do not know what would cause this…but without the file, I can’t really see what’s going on, other than the pictures you posted. Which display mode is being used in those screenshots?

Thanks,
-Jeff

Hi Jeff, thanks for the swift reply.

Away from my work MBP now, will check restoring display mode settings tmrw.

To your question: I am using “Rendered” mode.

Won’t be able to share the file for compliance reasons. I could try to reproduce this with another file.

Is there a chance to roll-back the Rhino for mac version to get a direct before and after comparison?

Hi Frank,

There’s a couple of us suffering from the same issue over in another thread:

I’ve tried resetting all the display modes but unfortunately it makes no difference. If there is a way to roll back the version of Rhino that would be great!

I suspect this is the same issue reported over in:

(which we can reproduce)

We are looking into this now.

In the meantime, here is a link to the Rhino 6 for Mac 6.18 build:
http://files.mcneel.com/rhino/6/mac/releases/rhino_6.18.19266.13352.dmg

We are tracking this issue in:

RH-55360 Rendered mode: lighting regression in 6.19 on some Intel GPUs

Thanks for directing to the right thread. Missed that one. Apologies for the redundant post. Will comment over at Update to v6.19 now dark grey rendered view and shaded view.

We have figured out what is causing this bug and have fixed and tested it. We plan to release an update to the 6.19 early next week with the fix for this bug.

In the meantime, you can work around this bug in two different ways:

  1. (Recommended) In Rhino 6 for Mac 6.19, when you start Rhino and begin a new modeling window, you can run TestToggleBuiltInFrontFacing. You will need to run this each session.
  2. Roll-back to 6.18 using the older distribution.

The latest update to Rhino 6 for Mac (6.19.19298.01152) should fix this issue.