RhinoMac service release 6.18: Black viewport in Rendered mode

Hi Im getting a black viewport when I switch to rendered mode. Lightning method: Default

Thanks :slight_smile:

Hans Henrik

Rhino 6 SR18 2019-8-27 (Public Build, 6.18.19239.01072, Git hash:master @ 9c57dd51ec74561d257c077569ad71da45599da1)
License type: Commercial, build 2019-08-27
License details: Cloud Zoo. In use by: Hans Henrik Ohlers ()

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G7024) (Physical RAM: 16Gb)
Mac Model Identifier: Macmini7,1
Machine name: Hans Henrik’s Mac mini
Language: en-DK (MacOS default)

Intel Iris OpenGL Engine (OpenGL ver:4.1 INTEL-10.36.25)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris
Displays: Thunderbolt Display (109dpi 1x), Thunderbolt Display (109dpi 1x)

Graphics processors
Intel Iris (1536 MB)
Thunderbolt Display (2560 x 1440)
Thunderbolt Display (2560 x 1440)

USB devices
Apple Inc.: FaceTime HD Camera (Display)
Apple Inc.: Apple Thunderbolt Display
Apple Inc.: Display Audio
Apple Inc.: FaceTime HD Camera (Display)
Apple Inc.: Apple Thunderbolt Display
Apple Inc.: Display Audio
Western Digital: My Book 1140
SONiX: Evoluent VerticalMouse 4
3Dconnexion: SpaceMouse Wireless Receiver
Apple Inc.: Apple Keyboard
Apple, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Broadcom: Magic Trackpad 2

Third party kernel extensions
com.3dconnexion.driver (1.1.0) 94E8C49C-EDED-3526-88BE-E7207560C0D2
com.Logitech.Control Center.HID Driver (3.9.8) no UUID
com.usboverdrive.driver.hid (3.4) E50155B9-337C-3812-B64B-80D8D48728FB
com.wdc.driver.USB_64HP (1.0.0) 73E84880-1183-640A-245F-F3F0348F45DE
com.kairos.driver.DuetDisplay (1) EAA64844-C599-3560-954D-31EBFC433071
com.webroot.driver.WebrootSecureAnywhere (18) FDC697A8-F725-3316-B9B8-DAB821A42DF2
com.usboverdrive.driver.bt (3.4) FF5EA238-E681-3663-AF2A-2AD5D9C718A6
com.getdropbox.dropbox.kext (1.10.3) F29DD0CB-48D6-311A-9B69-E39CF775493C

Third party plugins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
/Library/Frameworks/iTunesLibrary.framework/iTunesLibrary

Rhino plugins
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.18.19239.1072
/Applications/Rhinoceros 6.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.18.19239.1002
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.18.19239.1072
/Applications/Rhinoceros 6.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.18.19239.1002
/Applications/Rhinoceros 6.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.18.19239.1002
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.18.19239.1072
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.18.19239.1002
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.18.19239.1072
/Applications/Rhinoceros 6.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.18.19239.1002
/Applications/Rhinoceros 6.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.18.19239.1072
/Applications/Rhinoceros 6.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.18.19239.1002

The same file in V5 and in V6 versions -
Rendering mode is ok in V5.54 - but Render mode viewport is totally black in V6.18

  • would someone please help me out?

KITCHEN V5.3dm (3.9 MB)

KITCHEN V6.3dm (10.4 MB)

I tried change the Lightning Scheme in Rendered Mode to “No lightning”

Now in all viewports that are in rendered mode, I see a close up of one of the materials
and a notice " creating meshes…"

it all seems really weird , and I would even go as far as to say… a bug ? :slight_smile:

26

Its been 6 days now, 78 views, and not a single response…
Is this not something significant?
Please help. Such a bug (if that is the case) is quite deterring for my further use of Rhino 6, so for the time being, Im still using V5 for my projects, getting “this is obsolete software” promts everytime I open up Rhino.
So… please help me, what is causing this issue?

Thanks Hans henrik

Does this also happen in the current service release (6.17)?

I dont know if this would also be a problem in 6.17

the issue came when
A: I upgraded to service release candidate 6.18
B: I opened a V5 file and saved it in 6.18

How do i go back to 6.17 ?

oh sorry - I have just downloaded the service release 6.17 from mcneel.com

So… the file opens fine in the service release 6.17

View ports in rendered mode is black or with a sample of material on entire viewport in service release candidate 6.18

FYI

Thanks

Hi @ohlers-

Sorry for the delayed reply. I was finally able to track down the exact same MacMini (Macmini7,1) and test with the file you provided (thanks btw!). Unfortunately, I was unable to reproduce the issue.

Here are the steps I took to (attempt to) reproduce this:

  1. Launched Rhino 6 for Mac 6.18.19246.01092 on a Macmini7,1.
  2. Opened your KITCHEN V6.3dm.
  3. Set the Perspective viewport to Rendered mode.
  4. Orbited the view.

It all worked as expected. No black viewports. Please let me know if I’m missing something attempting to reproduce this.

The difference between the Macmini7,1 I tested with you and your’s is that ours is running macOS Mojave 10.14.6 (whereas you are running High Sierra 10.13.6). Apple does tend to fix bugs in GPU drivers - even for older ones - in macOS updates, so this might be the case with your issue.

I admit, it is odd that it did work with 6.17, but the black viewports appear in 6.18. It is possible we changed (maybe fixed!) something in your display code that cause this to stop working for you.

@ohlers have you customized your rendered display mode at all? If so, can you export it and attach it to this thread?

I think the problem with my black rendered mode in 6.18 has something to do with file data transfer from V5 to V6.
The file was originally created in 5.5.4 and then opened in 6.17 (which was fine). I then upgraded to service release candidate 6.18 and opened the original V5.5.4 version in the 6.18 service release candidate, and thats when I got the black window in rendered mode. I did not modify the rendered mode in that proces.

Today I have turned up antialiasing to 4X in 6.17, to have more smooth lines, similar to how it looks in 5.5.4. but this was another issue, unrelated to this thread.