Update to v6.19 now dark grey rendered view and shaded view

I’ve just updated to rhino 6.19 and now my shaded and rendered views are now a weird dark grey/black colour? i’ve tried different files and new files but still having the same problem - is this an intentional change to rhino or is this a bug? anyone else having this issue?

Having the exact same issue!

This is not an intentional change, as far as I know. Can you please attach the file where you are experiencing this? Also, please run SystemInfo and attach that here as well.

1 Like

File and system info attached. Thanks
ORCH_FIN.3dm (11.5 MB) SystemInfo.txt (3.5 KB)

Attached a before update and after update screenshot. Before the update everything was bright and Arctic seemed to function correctly. After the update, everything is dark and has a weird paper texture.

Please also find the model attached. Thanks. 191024_Updated Glitch.3dm (2.9 MB) System Info.txt (2.6 KB)

1 Like

exactly the same issue! its fairly blurry when moving the camera round in the rendered mode as well which it never used to be

Thank you for the files and the SystemInfo @shwarlottie and @mitchell1. That’s helpful. Unfortunately, I’m still not able to reproduce it on my Mac (I’m going to try to find a similar Mac and try again).

In the meantime, can you please send us your Preferences files? You can run the ExportPreferences command and attach the .plist file here.

Please see attached

ExportPreferences.plist (343.6 KB)

1 Like

I also encounter the same issue. Is there any way to get the previous version?

Ok, good. I can now reproduce this on a MacMini8,1 that is identical to @mitchell1’s (without a specific file or specific preferences). This leads me to suspect this is an Intel GPU-only issue. We will look into this.

In the meantime, here is a link to the Rhino 6 for Mac 6.18 build:
http://files.mcneel.com/rhino/6/mac/releases/rhino_6.18.19266.13352.dmg

We are tracking this issue in:

RH-55360 Rendered mode: lighting regression in 6.19 on some Intel GPUs

1 Like

@dan great, thanks very much!

Moving over from:
(Update to 6.19.19... Rendered view behaves substantially different)

here are my systemInfo and prefs. Hope that helps.

Pref_FrankS_work.plist (339.5 KB) SystemInfo_FrankS_Work.txt (2.6 KB)

We have figured out what is causing this bug and have fixed and tested it. We plan to release an update to the 6.19 early next week with the fix for this bug.

In the meantime, you can work around this bug in two different ways:

  1. (Recommended) In Rhino 6 for Mac 6.19, when you start Rhino and begin a new modeling window, you can run TestToggleBuiltInFrontFacing. You will need to run this each session.
  2. Roll-back to 6.18 using the older distribution.

The latest update to Rhino 6 for Mac (6.19.19298.01152) should fix this issue.

1 Like

hi, i am having the same issue with Version 6 SR31
(6.31.20315.17001, 11/10/2020)

Please try resetting your display mode to the default settings in Preferences > Display Modes. Also check if this happens with all files or just some. Also try restarting your Mac and Rhino if you haven’t already and the display mode reset doesn’t help.