Unwanted Gradient-like Shading

I’ve got this weird gradient on my surfaces in the ‘Shaded’ viewport. Can anyone point me to the settings to turn this off? It seems to be causing huge amounts of lag when i pan or look around in the viewport.

Thanks in advance.

Hi Kendall - in find Options > View > Display modes > Shaded, and click on Restore Defaults - does that help?


No, it does not. I’ve tried that. I’ve tried changing the Environments Projection to ‘Planar’ as well but it did not work.

Lets isolate the problem to that specific file, or see if other files do it too.
If it’s just that file, what’s different about it?
Maybe SelBadObjects to see if that finds anything.

If all files have this problem, please run the Rhino “SystemInfo” command and post that information.
Hopefully something will jump out.


Is the geometry far away from the origin?

This what i’ve got.

When I went to the Appdata to remove all settings and restore Rhino to its default settings, I got this view in the viewport instead of the typical flat coloring of surfaces that I’m used to in ‘Shaded’ view.

It seems like the surfaces somehow have gotten glossy/reflective and dark instead of the flat colour that uses the layer’s display colour?

So you’re running this virtualized? With RDP? Your OpenGl support stats are…dire, it’s a wonder it works on any level at all. You’re running Rhino kneecapped, with both hands tied behind your back, does a worse-case configuration even exist?

Black objects have always gotten grey shading, since ‘black’ would be useless for a working mode. Surfaces have a default environment map applied so that they don’t look completely dull and flat, which is again not very useful for a working mode.