Shade-Highlight Display Issue - Latest Release


I just updated Rhino to the latest release (see below) and now when I select an object with “Shade-Highlight selected surfaces and polysurfaces” adjacent surfaces become highlighted, as if they were also selected, just in a lighter hue. I attached an image of the issue.

This happened on my other computer after an update as well, but I thought it was related to using an old Quadro4000 as my GPU. It now happens on both machines.
Anyone else experiencing this?

Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Commercial, build 2019-04-28
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-HQIP7IJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 4-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.39

Secondary graphics devices.
NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 4-17-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-17-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - yeah - we have an example of this

Does this happen in any file? If not, can you send us a file that shows the problem?



I just checked, it’s happening in all the files I’ve opened so far. I tried updating to the latest GPU driver just in case but it didn’t have any effect.

Did you want me to send the file? Or was that only if it was happening in 1 file only?

Can you export the display mode and post that? If it happens in all files, I guess it must be the mode. BTW, just out of curiosity, and a possible clue - do you recall if the mode started in V6 or did you bring it over from V5?


It occurs in all the display modes I’ve tried that have “Shade-Highlight selected surfaces and polysurfaces” checked.
It’s only started over the last few updates in V6. It never happened during the earlier releases or before.

I attached my exported shaded mode if that helps
Shaded_Mode_With_Display_Issues_050819.ini (12.5 KB)


Hello - thanks, I see if with this mode, and not with mine, set to use shade highlighting. Can you tell me if this mode originated in V5 or was it made completely in 6 from the default shaded?
(BTW, here, it works correctly if ‘Advanced GPU lighting’ is un-checked)


The mode originated in V6. It was not carried over from V5

To your point though… I did reset the mode to default, then enabled shade highlight selected, and the problem did not re-occur.

When I tried the same thing with Arctic, resetting to default, then re-checking shade highlight, the problem persisted.

Maybe that helps. I attached my Arctic Mode export as well

Arctic_Mode_With_Display_Issues_050819.ini (11.5 KB)

Hello - yeah, I think I have it now - it happens if ‘Use advanced gpu lighting’ is set.

thanks for your help.


1 Like

My pleasure, thanks for helping me out as well.