Trouble With Shaded view in latest release candidate


Ever since the 1/7/2015 Release Candidate update I am having issues with my shaded viewport using my ShadedB display script. Attached is a screen grab of the display and the ShadedB file.

I don’t have this issue on my desktop which is on the same release candidate, just this laptop. I am running Win7 x64 and using an nVidia GTX 660M video card.

Any help to fix the problem would be much appreciated.

. Shaded B.ini (9.6 KB)

I don’t have this same card to test specifically but the mode works here using a desktop GTX card and the current driver from Nvidia 347.25

Compare the Options>View>OpenGL info in Rhino on both machines… it may be that the driver is old on the laptop.


I have compared settings on the two machines and I saw a couple things that are different. I am going to play with those later tonight. I did update the driver to 347.25 from Nvidia before I posted this topic.

Funny thing is, the laptop worked perfectly up until the RC of 1/7/15. Is there a way for me to roll back that candidate to see if that fixes it?



I misread what you wrote. I had compared Nvidia settings, not OpenGL. OpenGL settings are the same from my desktop to my laptop. I tried the couple small Nvidia setting differences too and that didn’t fix things either.

Can I roll back the RC?


Hi Jeff - look here:


In the folders there, I don’t know which exactly, you may find an earlier installer.


Thanks Pascal!

I did find an earlier version installer, but as you can see from the attached, it wants me to uninstall the current version before I can install the old version. This is going to be more trouble than I am willing to bother with. My Rhino is not the standard African model and it would take a while to tweak it all in.

How about a way to switch all the surface normals to positive Z axis? Is that possible? If I change the surface direction the shading is correct.

Thanks Pascal!

Am I dreaming?

It looks like you have the a custom backface setting in your display mode.
But I see from the .ini that it is not the case.

There were issues in SR10 that caused some backface issues in Holomark technical display mode, and this was fixed in SR11. Maybe this fix caused a new bug to appear.

PS! Probably the fastest way for a lot of surfaces to get the same surface direction is to join them together to a polysurface and then explode/extract them again.

Thanks for the info!

I did discover that joining fixed the issue, but I rarely have joinable geometry until I am almost finished with the job. I’m really surprised that McNeel has not made a way for automatically switching all the normals. Do you think this could be done with some kind of macro? I don’t have that skillset and knowledge but it seems to me that this would be something that was useful for machining and somebody has already solved that puzzle.

This problem exists in more than my custom shaded view, it’s in some of the std. Rhino views too.

Here is a script from my library that should do what you want… Easiest way is to make a toolbar button or alias for it (it’s not drag and drop) or just run it from the EditScript editor if it’s only for occasional use… I can translate this to Python if it’s for use on a Mac…

Unifies z-up:
UnifySrfNormalsZup.rvb (1.4 KB)

Unifies towards a picked point:
UnifySrfNormals.rvb (1.1 KB)

1 Like

Thank you so much!

I’ll try these on my laptop tonight.

A bug for lighting backfaces in the Default Shaded working display mode has been fixed and tested for SR11. It made backfaces look a little darker when they should not have been. I don’t think the fix is in the current release candidate so you can’t get to it yet. Maybe next week.

Perfect! Thanks John!

Scrips worked perfect! Thank you so much!!!