Unroll multiple polysurface?

I’m trying to unroll some pieces but any plugin in grasshopper seems not works the only way what I’m thinking is viable is doing it in rhino but is about 200 pieces so could I unroll multiple pieces at same time?

I’ve never run a code so I suppose is the only way

i made a little script, not perfect, but may be helpful.

let me know.

Edit V2
Added support for polysurfaces, possibilities to choose a placement point, and prompt message during process.

UnrollMultipleSfr-V2.rvb (1.3 KB)

1 Like

And here’s mine - forgot to respond this morning…

MultiUnroll.py (7.4 KB)



thanks guys

guys i think the command that is working is “unrollsrfUV” because i got an error in the surface with 2 scripts in the the ribs, check it.

result with unrollsrfUV"

Hum, i think unrollSfrUv correspond to Smash , there is no Smash command in VB only UnrollSurface, may be in Python , Mitch ?

1 Like

UnrollSrfUV is the old version of UnrollSrf from V4 and earlier. Sometimes it still works better than the current version, but it would be good for the McNeel developers to have examples of where it doesn’t work so that they can improve the current command.

@HEEN - if you could post an object or two where UnrollSrf is not working correctly so someone can have a look?


1 Like

Smash is different than UnrollSrf or UnrollSrfUV, and works with doubly curved surfaces.

I think does not work for any piece.

What about squish? could be possible use that command?

Attach a file with 60 pieces to test just in case.
ribs.3dm (1.7 MB)

when i run unrollSfrUv in rhino 5 smash kind is launched, what i thought was old smash version.

No squish command in VB :disappointed_relieved:

edit : tried with Heen file , unrollsfr produce kind of ghosted surface

:cry: well I think I need to start to unroll one by one :frowning:

is not a scale/Units problem ? in your file shapes are really really small , i tried to scale up your shapes, and script seems to work better .

I started to model in meters but to make a mock up I scaled to cm it’s about 80 cm x 50 cm

Your parts are way too small and the absolute tolerance of 1e-07 is not good - you shouldn’t as a general rule go below 0.0001. I changed your file to cm (scale by 100) and your tolerance to .001 and all 60 unrolled perfectly here in about 3 seconds.



actually that pieces were scaled I mean are in cm maybe i going to try with tolerance,

is possible use it as component in grasshopper?

not successful

BTW, if you are going to be cutting these out with some automated process (laser, cnc, etc.), normally the file should be in mm at the model/object scale.

The script is written to be Rhino-native, it would need a significant re-write to function as a GH component (but it’s possible).

I don’t see any that look like that here from your file… The slots all look to be 2.5mm and correctly formed.


1 Like

You are totally right I’m going to check in that format I hope it works

— Yey it’s working nice :slight_smile: thanks

To the best of my knowledge, UnrollSrfUV is new, improved version of the UnrollSrf command.