'Unreadable geometry object' and 'history record table...' can the file be saved?

Hi there!

Can anything be done to save the work when opening the rhino file and getting these messages? (First the ‘…geometry object’ and then the ‘…history record table’).
When the file finally opens there is almost nothing left from the original Rhino work (chair).

I tried to print the drawings from the last part of my Rhino chair - but suddenly I don’t have any chair :frowning:
Unfortunatelly the last file copies / backups are not so new.

I run in to this issue every now and then, so it would be nice to know if something can be done in these type of issues?



CanItBeSaved1 CanItBeSaved2

What Rhino version are you using?

Because of the T-Splines I’m still useing the version 5 (don’t quite know how long I could use the version 5 if updating to Rhino 6?).


Your v5 license is permanent. Even after updating to v6 you can use your v5.

Really good to hear! :slight_smile:

If I remember right, there was a plan to limit the usage of Rhino 5 (at some point) after updating to version 6, right…?


Nathan ‘jesterKing’ Letwory mcneel@discoursemail.com kirjoitti su 11. marrask. 2018 klo 16.40:

Well, you’ll always be able to use your v5, but after upgrading you still have one license. This means that using on two machines at the same time is prohibited (i.e. v5 on one, v6 on the other), just like with one license.

Anyway, I’m not sure what happens to the geometry. Perhaps @pascal could take a lead in further investigating?

Terveisiä Turusta (:

Yes, naturally I’d like to update to 6, but at the same time keep the 5 alive because of the T-splines. And all in one machine - and for one user.

Sounds like it’s possible. Nice!

And yes, would be nice hear if something could be done to get ‘the lost chair’ back…


Nathan ‘jesterKing’ Letwory mcneel@discoursemail.com kirjoitti su 11. marrask. 2018 klo 17.21:

Hi Johnny - is there a 3dmbak version of this file in the same folder? That should get you most of it back, provided you save relatively regularly… But, if indeed

I hope you are saving backups somewhere yourself?

I see the drive is a synced drive - that may be an added complication - does this happen with other. local, saves?

Lastly, try Rescue3dmFile > Recover and see if it gets you anything more.


Yes, there is. But when trying to open it, the text attached appears.
I can’t quite translate it, but says something like ‘The file can’t be opened because some definition-something is wrong…’.

See more information in log Xsxtrance.exe (or something)…

Yesterday when I opened that file for the first time, the only thing which was left from the chair I saved with a new name. And today when opening that new file, there was nothing left and a text appears ‘this is not a Rhino file’ (???). …even I could open the file.

I do backups - or more like copies from the Rhino files - every now and then. I actually work in Google Drive, and I quess Google does some automatic backups, or something like that(?).

What is the ‘Rescue3dmfile’ you mentioned? Is it a command somewhere? In Rhino? (Couldn’t find it there).

Luckily I found some older backups with tolerable design information about the chair. Have to live with that :wink:

But still wondering what are these funny little issues…?


Hi Johnny - my Finnish is not what it once was - can you tell me more or less what that error says?



“Starting of the application failed, because its parallel (side-by-side?) definition is incorrect. You can get more information by checking the event log of the application, or from the command-line tool Sxstrace.exe”

Dont remember Finnish even You must hear it all the time in your country? :thinking:

Seriously: Nathans version is pretty sure the right translation.
‘Rinnakkais…’ means side-by-side and ‘…määritys’ means definition, plus all the other words fits as well.


I’m pretty sure that’s it, Thank’s!


Hi Johnny - are you opening the 3dmbak file from Rhino or from Windows Explorer? If th latter, try it from Rhino or even just rename the file to FileName.3dm and see if that works (3dmbaks are just 3dm files)

Also, until we figure this out, I’d not work from a GoogleDrive folder directly but move/copy the files there to sync. For what it is worth, I’ve never seen this happen here and I work from my Google Drive all day long…


No, I never open any Google Drive stuff through browser (only in some individual cases).
Changing the end of the name to .3dm didn’t help, and copying files to my desk and opening them there didn’t work either.

Same text and things appears when opening…


Hi Johnny - this is somewhat of a shot in the dark but I might try running the Rhino installer and choosing ‘repair’ (from the Windows control panel, Programs and Features)


Holy cow!

What happened: I don’t quite understand the workflow of the ‘repair’ command, so I downloaded the whole Rhino 5 (again), and after downloading lost all my Rhino backup files (but not the original ones).
Plus couldn’t open the problematic file in Google Drive.

BUT when opening the problematic file which I moved to my desktop (same as the one I mentioned above), it opened and the chair seems to be ‘nice and untouched.’

Interesting… :thinking:

Pascal and Nathan, great thanks from all your efforts!


Hi Johnny - I’m glad you got your file back but I have no idea either what happened there…


Happy to hear you can continue your work!