Unexpected Shaded View Display Behavior: Geometry Ghosted/Wireframe

A file I’m working on just started having a weird display issue:

Geometry in any view with “Shadows” enabled in the display panel are showing as ghosted or wireframe in the viewport. While I’m panning/orbiting/zooming, everything displays normally. File isn’t particularly large/complex or anything.

I copied the geometry into an empty file and the behavior continued.

Un-Checking “Shadows” in the display panel fixes it.

My graphics driver is up to date.

I assume restarting my computer will fix the issue, but I’m curious if there’s another solution or any explanation of what’s going on.

Screen Capture:

System Info:

Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Commercial, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 48Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1660 SUPER (NVidia) Memory: 6GB, Driver date: 5-19-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.95
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-19-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\dylan\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22102.1509
C:\Users\dylan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”
C:\Users\dylan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hi Dylan - if you disable Enscape in Options > Plug-ins page, and then close and reopen Rhino, does this behavior change?


Nope, no change.

Hi Dylan - if possible, can you make a copy of this file, delete most of what is in it, leaving some objects that still show the problem, assuming that they do, send us the file to tech@mcneel.com, with a link back here in your comments. If the problem is not evident in the sub-file, send the whole thing.
I’d also check with Elefront disabled, ( Rhino closed & re-started) though it seems unlikely to be the one.


Done. And in putting that file together, I found two potential culprits:

–When I exploded or removed block instances of a door latch that I had downloaded from the manufacturer (I believe it was this model), the issue disappears.
----It only worked when I exploded /all/ the block instances.
----I tried replacing the geometry inside the block with just a single basic shape, this had no effect.

–I had some objects set to different display modes using “-setobjectdisplaymode” command. When I changed everything back to default display mode or ghosted, the issue disappears. It seemed that it was having objects set to “Wireframe” that was causing the issue. When I changed objects back to “-setobjectdisplaymode -wireframe” the issue would come back, but I could set objects to “ghosted” with no problems.

Digging a little further, it looks like the issue occurs specifically when I use “-SetObjectDisplayMode -Mode -Wireframe” on a block instance

The issue doesn’t appear immediately, and more objects appear to be affected as I set the display mode of more block instances to wireframe.