Shaded view mode display artifacts and ghosting

Hi, my first post, and unfortunately it is to deal with an issue I am having with my shaded display mode,

I have read the posts related to view and display issues, and none solve my issue. The post that came closest Strange Display Behaviour spoke of the “testbiasfactor”, which I read about in the wiki pages posted by John Brock, however this does not seem to be my issue. I was running my Rhino on Windows8 and downgraded because of issues I had to Windows 7. In Windows 8 I had no such problems, and now that I am using WIndows 7 they seem to have cropped up. The pc is the same, a Dell Inspiron i7, only my operating system is different, which means drivers are different.
In Johns article I noted that intel graphics cards do not work as well, and NVidia ones are fine. My pc seems to have both. Is there anyone out there that can shed some light onto this problem I am having, who perhaps know of a setting I can change somewhere that will improve or correct my issue. The below images show some of the artifacts I am dealing with, ghosting, my model edges becoming invisible, and transparent in places.

If more info or images are required let me know and I will provide them.
I will monitor my post all day to see if anyone has some insight. Thanks, Rob.

Normally, I’d check the distance the model is from the world origin in the Top Cplane and move the model closer if it’s far away. Also run SelBadObjects if that doesn’t help to see if this could be geometry related.

Your description of this only occurring on Win 7 makes me think it’s drivers though. Can you post an image of your Options/View/OpenGL page please?

1 Like

Hi Brian, thank you for responding to my post. below is the requested screenshot.

I have checked the distance from 000 and I am pretty close. I also ran the SelBadObjects command and no objects were identified. I must add as I have just performed the downgrade I have not worked on many Rhino files yet, and since my post I have opened a file from a colleague of mine I am working with, and his file on my machine does not display the same issues. Regarding my drivers, I have checked the drivers, and I am running the most up to date drivers.
Thanks for the assistance.

Hi Brian, I must also add the file I am working in has both nurbs surfaces, and mesh elements.
Thanks, Rob.

Check the top box ‘use accelerated hardware’ on that page and test your file again please. Send a screenshot of the page with this checked if the issue persists.

EXCELLENT, thank you. Brain this has resolved my issue, thank you. Just to get a little more from this post, does the fact that I have both mesh and nurbs objects cause this phenomena?, and is this a typical fix for working with both types of geometry.
Thanks again, Rob.

Hi Brian, back again. My situation is greatly improved, and I could easily work with my drawing like it is now, however, there are still some slight visual disturbances, and was wondering if I could adjust the settings in the open GL tab that could further improve my display. below is the screen shot you requested and one showing the issue I am mentioning.

Thanks, Rob.

I have antialiasing set to 4x in my settings:

You could see if that makes any difference in your situation.

Thank you Mcramblet, I have made the antialiasing setting you suggested, and it has improved the display further. I still have a small amount of bleed, see image below. I took it up to X8 and no real change.

This is all really great. If there are any more suggestions to further improve the display, I welcome them. Thanks.

Also, take a look at this page, towards the bottom.

It looks like this may be similar to what you are seeing. This whole section of the wiki may help, too.

I have been to this page when initially attempting to resolve my issue, and nothing worked in the same fashion as the selecting of enabling the accelerated hardware mode did, and then your antialiasing setting. The problems on this page do resemble my issues, but the solutions did not resolve anything.

I do wonder why this is happening in only one file which does share mesh and nurbs geometry, and not in another on my system that does not have mesh geometry?

I assumed (and maybe shouldn’t have), that you’ve tried adjusting your mesh settings:

I generally keep it on “Smooth and Slower”, but at times and with certain models, I need to bump it up by going into the custom settings, if it isn’t displaying accurately.

My mesh settings are as yours are smooth and slower. Do you think to work with custom settings will resolve this?

I have never messed with these before, and will take a look. I’m a little reluctant to mess with number settings, as this has been my undoing in the past, where I have had my file crash, and well we all know what its like to lose work, even if its only a small amount.

There are custom mesh settings that I sometimes use, but sometimes I simply bump the density all the way up to 1 and leave everything else alone. You could see if that has any effect on your views. That one change alone often makes a big difference on some models.

I have solved my issue 100%, and I am to blame. I believed I was working near the 000 point in my virtual space, a confusion brought about with swopping between files, no real excuse other than too busy to do something thoroughly, and just wanting a fix so I could get on with it.
OK so I deiced to go and re check this point, and discovered the drawing I am working from is a far way off from the 000 mark. I have moved my model, and voila all is good, in fact it is perfect.
I have learnt a lot from Mcramblet and Brian, and thank you both for your time and effort in assisting me in getting this right. Below is how my model should have looked the whole time, crisp and clear.

Just to add to the post problem solved.

This fixed it for me. Thanks Brian!

1 Like