Ghosted View not showing objects in right order?


Hi there,

I am a bit stuck - the ghosted view doesn’t show as I would expect - the blue inner structure is obstructed by frames which run behind it - is there a setting I can change to adjust it?


Hi Ewa - can you post the file or send to with a link back here in your comments? Do the camera coordinates look reasonable (Properties panl, with no selection) or very large?


column for rhino.3dm (1.5 MB)
Hi please see attached - I removed parts of the model as I am not allowed to share it, maybe I have wrong expectations of how it should look like; X-ray seems to look better but I wanted surfaces to be shaded for better illustration of the different elements in the model

Hello- here is how that detail looks here in Ghosted.

Can you please run SystemInfo in Rhino and copy/paste the results here?


It is almost the same, I removed Isolines in my set-up, and some elements in the file I’ve attached were not included in my original picture at the top. I am mostly bothered about the back detail showing through - which is exactly the same on your picture. I guess this is just the logic of ghosting - thanks for clarifying this to me

Rhino 7 SR17 2022-4-12 (Rhino 7, 7.17.22102.05001, Git hash:master @ 13b57035af8fb22da005ef72c56e4555d9dbcfe3)
License type: Educational, build 2022-04-12
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 3.4Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon HD 7560D (AMD) Memory: 1GB, Driver date: 11-4-2015 (M-D-Y). OpenGL Ver: 4.5.13399 Compatibility Profile Context 15.201.1151.1008
> Accelerated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.5 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.40
Driver Date: 11-4-2015
Driver Version: 15.201.1151.1008
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

It would not hurt to update the AMD driver, from the AMD website, if there is an update available there.


thank you; my PC is a bit underwhelming, it is on my to do list to uplift it.

I’ve touched up the drawing in Krita - and am attaching the snip just to be clearer on what I was aiming for

One thing you can try - and it may be limited by the low power GPU but you can use the regular shaded display mode and set layer colors to various amounts of transparency - not as convenient but very ‘tuneable’.


Thank you, I think this is something to play with, I thought originally to change materials to transparent - but I think that would work in rendered view rather than in shaded.

What you’ve done here is very much what I am after :+1: