Unable to refresh license?

I upgraded to Rhino 6 a couple of months ago and suddenly am receiving this message whenever I try to open the program: I just reset my password and then got the same message once again. What’s going on? I’m losing a lot of faith in this new version. I should also add that although I received an email stating that my password was changed, Rhino does not seem to recognize the new one either. Thank you.

As the system is set up at the moment, your Rhino account credentials expire about every 90 days or so. At that point, you will need to login to your account at https://accounts.rhino3d.com/ to refresh your credentials. It’s not clear from you message if that is where you logged in.
@aj1 should be able to tell you more about how this works.

Yes, that’s where I logged in but as I stated, the system did not recognize my old password, nor the new password after I had reset it. I guess when Rhino stops working I’ll have to pursue the matter further, at my inconvenience.

Hi Ethan,

Every few months or so your credentials expire, so you need to login to your Rhino account again. If you forgot your password, you can always reset it by clicking “I can’t login” on accounts.rhino3d.com.

I’d be happy to help you further if you need more assistance.

Thanks for your reply Andres. I reset my password for the third time and now things seem to be working, though I have no idea why.

1 Like

I need to refresh my license as well. Since quite some time I get the message. But Even when I loggin to accounts.rhino3d.com, rhino is not able to refresh my license. It says that I have some 70 hours left. accounts.rhino3d.com not responding at the moment at all. The constand notification and browser opening is very annoying and it does not work anyway, browser is not able to open the link, not even when copy pasting. Need to be able to work, hope there is a solution to this.

IIRC, clearing your browser cache might help…

1 Like

Everything on our side with your GMX account looks fine.
Can you login using the Web portal?

1 Like

Somehow yesterday whatever I tried logging in just resulted in an endlessly loading blank page. However, today, it worked fine. Login and license refreshing is done. There were a few sites not responding yesterday evening, so I guess this was due to higher corona internet traffic, maybe?

Immediate panic instead of keeping calm.


1 Like