Rhino License says it's expired?

Hi! I’ve been trying to access my rhino 6 app for a while now with no success. When I try to open the app, a pop-up says the licenses in my account have expired. I know this isn’t true. I just renewed my license earlier this year when my rhino 6 trial was over. After putting in the key I purchased, it worked perfectly for about a month before it started telling me it was expired again. I have tried re-entering my license key and it has done nothing. The license still shows up on my account, so I’m not sure what the problem is.

You have a valid license in your Personal cloud Zoo.
I also see you unsuccessfully tried to add the license to a stand alone computer yesterday.
You can not deploy your license in multiple places simultaneously.

When you start Rhino V6, can you press the Login button?

Can you go to https://accounts.rhino3d.com/?controller=home
login, and see your license in your personal license list?

Thanks for getting back to me. Yes, I can see my license in my personal license list. I honestly wasn’t sure what I was doing yesterday when I tried to add the license to a stand alone computer. It was just something I hadn’t tried yet. The computer I did that on is the only computer I have been using Rhino 6 on. When I start it and login, I just get the same message saying my license is expired.

Can you get into Rhino?
If so, try typing the Logout command.
This will close Rhino.
Then start it again and Login.

Any luck?

I was unable to get into rhino, but when I tried to open it and hit “cancel” on the error telling me my license was expired, the initial login window popped up, the one that has options like login, enter product key, purchase a key, etc. I hit “logout”, then went and logged back in. This did make a change and rhino got further along in trying to start up when I tried to open it. But before it was finished starting up, the app closed and I got an error report page. I’ve tried it a couple more times just in case and just continue to get error reports.

Are you sending in the error reports with your email address and a description of what you were trying to do?

Yes, should I wait on someone to get back to me by email?

Hi @mfoisy, I’m AJ, one of the developers at McNeel. Can you please PM me your email address you typed in the crash report?

I have exactly the same problem with my new Rhino 7. Pressing the blue ‘Add license’ button (with my license key from my receipt), nas no effect whatsoever. The licence expiration notice box still pops up. Please let me know how I can start working with my Rhino 7 again. THis is pretty urgent.

Hi. I just fixed my licence expiry problem. I was using MS Edge browser (latest version), so I logged out of my account, set Chrome as my default browser and restarted Rh7. When the licence expiry notice appeared again I was shuttled to my remote Zoo account and logged in again, this time using the Crome browser, and was able to quickly enter and update my account with my new licence. Rhino 7 then started ok. Problem solved.
Cheers