Unable to refresh licences

This warning returns every day. I use Rhino 6.10.

I ran Logout command hoping that Login command would refresh my licenses. After the Logout Rhino asked me for permission to update to Rhino 6.10. This was strange request because I already installed Rhino 6.10 a week ago. I gave the permission and Rhino 6.10 was installed again. At the end of the re-installation Rhino asked me to Login and launched the browser. I logged in, went back to Rhino and realized that I have lost two licenses (shown in the following screenshot).

I tried to login again several times, but it did not work.

Hi @Andrew_Nowicki,

There are a lot of moving parts here, but can you try running a Penguin or Flamingo command to see if it prompts you to get a license?

Yes, it worked. When I set current renderer to Flamingo, Rhino fetched Flamingo license. When I set current renderer to Penguin, Rhino fetched Penguin license.

1 Like

Since a week or so now, I’m getting these fairly frequently in both V6 and V7


OK about the driver update, I will do that soon, but why the license problems?

I didn’t have the WIP installed on this machine before, I installed it also about a week ago and it seems the notifications started then…

@Helvetosaur can you double click (Or select and click Details) the licensing notification to see what the issue may be?

I bet the update may have somehow deleted your authentication token and thus you’ll need to login again.

Yep, that was apparently it… thanks.