"mactext" command prompts before "move" in command line


#1

Hi,

I just upgraded to the latest version of Rhino-mac.
I’ve noticed that when typing M in the command line “mactext” has priority over “move”. Is there a way to change this? I’ve tried on rhinoceros-commands-customize creating a shortcut for “move” but that’s not exactly what I want, I would like to prompt the command by using M key followed by enter (spacebar), in the same way that it works with R for “rotate”, T for “trim”, etc.

Thank you,

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-06-10 (515)
OS X version: Version 10.9.3 (Build 13D65)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: iMac13,1
Processor: Intel Core i7-3770S CPU @ 3.10GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 512 MB
Memory: 512 MB
Screen size: 1920 x 1080
Displays: iMac

Third party kernel extensions
com.Cycling74.driver.Soundflower (1.6.6)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
ELECOM: ELECOM Scope Node Mouse

Bluetooth devices
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.21 310.40.35f08
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


Help with alias weirdness
Help with alias weirdness
#2

Yeah, that seems wrong, and even going into preferences and setting “m” as an alias for ! _Move does not help, if you type “M” and enter, MacText still gets called. Normally, aliases should have precedence over autocomplete - at least it is that way in Windows Rhino…

–Mitch


#3

fwiw, this release changes the way macros are stored.

The storage of Aliases has changed. Previously, only your changed aliases were saved, and these were automatically merged with (and overwritten by) the default set of aliases. This made it impossible to delete default aliases or change default aliases. With the 2014–06–10 WIP release, this is changed.
If you had custom aliases prior to 2014–06–10 and also want to use default aliases, do the following:
In Rhinoceros > Preferences > Aliases, export your aliases to a text file using the gear pulldown menu at the bottom of the window.
In the same gear menu, select Reset alias to default.
In the save gear menu, select Import aliases from file… and navigate to the file where you saved your previous aliases. This will merge your current custom aliases with the default aliases.

so maybe something needs fine tuned with the change.
for me, i followed those instructions and M is still working as my move alias.


#4

same problem here, ‘m’ leads straight to mactext. also can’t even find mactext in the command editor


#5

seems like making an alias in preferences-alias works.
make an alias named ‘m’ with the command makro ‘_!move’ .
m is now listed first!


#6

Hmm, that didn’t work on my end… I’ll try resetting the aliases as per Jeff’s post later…

–Mitch


#7

it didn’t work on my first try either, but it did surprisingly after restarting rhino


#8


(Marlin Prowell) #9

In the current release the list of available commands is not rebuilt when an alias is updated or added, but only when Rhino is started. This will be fixed in the next WIP release.