Two finger pan broken

I just updated to Rhino 7 since I have an M1 Mac now. Oddly enough, a bug I had in Rhino 5 seems to still be there. I use the Mac’s two-finger gesture to pan my model, but sometimes it randomly switches to zoom instead of pan (like the command key is supposed to do but I am not hitting command). I need to quit and restart to fix it. I see dozens of posts here about issues with the two-finger gestures on Macs but somehow no fix for this long-standing bug?? It seems to be even worse on Rhino 7, it crashed after being in that bad mode for awhile.

Bump. I’d appreciate a reply from a developer here. I could deal with this thing under Rhino 5, but crashing takes it to a new level of problem under Rhino 7. I submitted a crash report through Apple.

Hi @scottfsmith ,

I haven’t seen this myself on an M1 here. Can you email tech@mcneel.com with a sample file in which this occurs and also indicate what you’re doing when it happens. For instance, are you working in a specific view or layout or in the middle of a certain command. We’ll need to also get the results of the SystemInfo command run in Rhino 7 from you too. This may have some clues as to why you’re having this issue. One last thing, when the crash occurred, did you send in a crash report to McNeel as well and if so from what email address? Let us know in the email to tech@mcneel.com please, this will be one we can look up internally to try and troubleshoot it. Thanks.

Sure will do. I just tried to reproduce it and could not but will be paying attention. Note that the pan did freeze several times, that is another common problem. It basically stops being able to pan for awhile, or it may be jerky, but fixes itself eventually. All of the issues seem to be with the multiple finger gestures, using two fingers to pan, two finger pinch to zoom, and three fingers to make selections. I think it is some combination of those gestures that are leading to the bug.

The little Apple dialog popped up to report a crash, I assumed you were getting those but it sounds like not? Let me know how to send you a crash report and I will do it next time.

Hi Scott -

The Apple dialog is a completely different system than the Rhino crash reporter and we do not get that information. When Rhino crashes, and Rhino catches that, it will open its own dialog. From your description, that is not happening on your end. If Rhino hangs indefinitely, it is possible to generate a report manually but it doesn’t sound like that is the case in your situation.
Any help with steps to reliably reproduce this behavior is welcomed!
-wim

OK it just crashed again. I had the app running in the background and had slept the computer. When I fired it up again it was doing the zoom instead of pan with the two fingers, and this messed up the view and I could not find my model so I did the 4View command to reset it … that is when it crashed. No crash dialog other than the Apple one opened.

I’ll send in a report to the above email now.

Thanks @scottfsmith That sleep detail may be the key, I’ll try reproducing it again with your file. I have the email.

Note I am not sure if I had slept it before the previous crash, it might be sufficient just to have the app in the background. But, I was not paying a lot of attention that time. It definitely needs to be in the background for a period, and also perhaps hidden (with command-H). Some combination of sleep and/or in background and/or hiding the app plus finger gestures and a 4View at the end for the crash.

Hi @scottfsmith, I’m not having any luck so far reproducing this here on an M1. What are your two finger click trackpad settings in macOS? Are there any changes you’ve made to this area of settings? These are mine…

I have all of those set. There are two more tabs on that pane, and under the other two tabs I also have all on except for App Exposé. I think you need to set all the stuff in the Scroll & Zoom tab in particular, that lets you use two fingers to pinch to zoom.

Note that in terms of operations I am doing very minimal things, just importing some 2D points, editing them, CurveThroughPt, and Revolve. With lots of two-finger pinch to zoom, two-finger drag to pan, and three finger selection of points.

does it still crash if you disable the two-finger gesture in Rhino (will pan with one now)

That screenshot is an old MacOS, there is no such option now. I am running the latest, Monterey, 12.1. I don’t see any place to configure the two-finger pan or the three-finger selection, only the two finger pinch to zoom. These might just be built-in now.

Hi Scott, Its in the rhino>preferences>trackpad. I’m on 12.0.1 on a recent rhino build. To pan its actually cntl+one-finger. Trying to help determine crash variables, would be good to test.

Ah, I thought that was the OS prefs. It looks like it is control+click+drag for pan without that option (also need to click before dragging). Note that I am not doing any clicking on any of the gestures I am doing. I’ll try this mode, my guess is I won’t get any crashes with the two-finger pan turned off.

Nope I take that back … just got a crash with two-finger pan turned off. I did a bunch of pinch zoom in-out and editing operations with three-finger selections, then tried a 4View, Boom. The zoom got a bit glitchy which is why I decided to try the 4View to see if it was in a bad state.

1 Like

Also it looks like sleep and background stuff is not necessary. I fired it up, did a few edits (three finger selections, lines, revolves), the two-finger zoom glitched, and then 4View crashed it. I saved the crash log in the Apple dialog, let me know if you want it.

How have you enabled three finger selections? I see that one finger click and drag or one finger tap selects but here three finger tap and drag up or to the side switches the app in macOS.

Thats odd. I think they may have disabled that option in one of the OS upgrades but did not change past installs. I un-selected the “Swipe between full-screen apps” and re-selected it and now I no longer have the three finger drag selection working.

I’ll see if I get the error again.

OK got another crash. Did not do any 3-finger selections. I am getting better at repeating this bug at least…

Okay thanks, several of us here with M1s have been trying and so far can’t reproduce this. We’re updating one M1 Max to your version of Monterey to try again. Sorry you’re having this issue, we’re not sure yet what the cause is but my guess is that it is a system specific setting. If you are willing to reset your Rhino 7 plist file that would be the next test I’d want to try on your end. See Rhino for Mac - Preferences [McNeel Wiki] for instructions on saving a current copy of your plist and then resetting it. If that is the issue, getting the saved plist from you would be the next step so make sure to save it before resetting.