Trouble with lofting closed curves

loft.3dm (69.4 KB)

Hi, I need to loft these curves. It doesn’t work. Can someone see the reason why? Any advice?


Hi estu - the lower three curves are not closed (`SelOpenCrv)


CloseCrv can be used to close the curves.

I know, I accidentally uploaded the file with unclosed lower curves, and different directions. But even if you close them, and adjust direction, loft doesn’t work for me wihtout rebuilding.
I uploaded the correct file.
loft-v2.3dm (69.8 KB)

Hello - I see that - I’ll see if I can figure out what is wrong.
One thing is there are kinks in the curves - they are not tangent internally. Loft should still work, but that is what I’d look at first - is the intention to have smoothly connected curves?
If you Explode and rejoin all the curves you can get an object from Loft, but getting a nice object from these curves will be problematic - do you have an image of what you are shooting for? I can’t help but think there is probably a better way.


Yes, the intention is to have smoothly connected curves. I can’t show you an image, because this is something I’m trying to create from scratch. Actually it’s a glass panel shell around a building, and those curves represent the buildings interior around which the shell is supposed to go.
If you choose “Loose” as option in loft, you’ll get, more or less, what I am after. It’s just that loose, is a bit too loose. I need to get it a bit tighter around those curves. I was thinking to use history, and then manually adjust the curves after the loft. But if there is any way to do this precisely with “normal” loft; that wold be a great help. Thanks!

Hello - well, I’d certainly spend some time with the curves and make sure you have clean smooth curves if that is what you want - what you have is a series of more or less (often less) tangent segments and these kinks do not line up, particularly, from one curve to the next…

Use CurvatureGraph and (on the exploded segments) GCon to test continuity.