Trouble with installing Keyshot plugin

I’ve tried to install the Keyshot plugin for Rhino 6 on Mac( ). Even though the .marchi file seems to run succesfully, the commands are not working after the Rhino restart. Also the plugin isn’t listed in the plugin manager.

The kind of odd thing is, that the plugin is working in the Rhino 5 version on the same computer.

I’ve tried to figure out if the plugin for some reason was installed in an old Rhino directory, but no matter where i try to copy the plugin bundle to, Rhino 6 doesn’t detect it.

I dont know if its a bug, or if i’m doing something wrong, but any help would be much appreciated! -Thanks

Did Keyshot release a V6 version of their plug-in?
Generally, a V5 plug-in can’t run in V6.

I’ve tried to contact Keyshot for clarification on this, without any response yet. However its stated on this page,, that plugin should be working with both Rhino 6 on Windows and Mac.

I’m currently running Rhino 6 in a trial mode, I don’t know if this could be the reason why it will not work.

So I heard from Keyshot today, and they told me that their plugin is currently NOT supported in Rhino 6 for Mac.

They also created a post in their forum, that can be found here: