Fail to install Keyshot 6 plugin

Download from here

official tutorial

The plugin is flaky, but I don’t know why. For me, sometimes it works and sometimes I get the same error. Try first without KS running. Looks like you posted on the KS forum too…Good!

For this reason, I typically just import or update the .3dm.


Noticed there is a 1.1 version of the KS Rhino Mac plugin at Luxion. I had version 1.0. Installed 1.1 and have not received the Connection error… since.

We installed v 1.2 / v 1.4 on 2 different Macs, but it always gets installed to the Rhino v5 Library path, although Rhino6 opened itself upon clicking the .macrhi plugin file.

Did anyone else have the same problem and solved it?


I’m sorry to say that I don’t know what is going on with Keyshot, but I do want to (temporarily) clear up a bit of confusion.

The situation with ~/Library/Application Support/McNeel/Rhinoceros/ … is confusing. (So confusing that I sometimes forget what the situation is until I look at source again).

In short, there is no version specific plugin folder. ~/Library/Application Support/McNeel/Rhinoceros/MacPlugIns is the folder for both Rhino 5 for Mac and Rhino 6 for Mac.

The ~/Library/Application Support/McNeel/Rhinoceros/6.0 folder is for settings. I know it contains a subfolder called Plug-ins which is confusing to me. But if you dig into those Plug-ins subfolders you will find settings files, but they should not contain assemblies that we load.

Ok, back to ~/Library/Application Support/McNeel/Rhinoceros/MacPlugIns …both Rhino 5 for Mac and Rhino 6 for Mac will attempt to load assemblies from this folder. Since most RhinoCommon plugins will be compatible with both 5 and 6, you should be good. (Incompatible plugins ought to be reported as such…usually in Rhino 5 for Mac).

I know this probably doesn’t clear up any confusion and it certainly doesn’t solve the Keyshot issue. I believe the .macrhi installer engine is doing what it is designed to do and putting the assemblies in the MacPlugIns folder.

Since everything seems to work as planned, what can be done to get to work in RhinoBeta?

As described previously, on installation this happens:

  • Rhino 6 Beta opens
  • Keyshot8Render, etc. commands appear in Rhino 5
  • Keyshot commands in Rhino 6 are missing.

So what to do / who to blame for this?

I’m still not sure. Who to blame? Probably us, but that’s little help.

I just got ahold of the plugin. Let me take a look. Tracking this in RH-53344

1 Like