Transparency cause ghosting in rendered mode

… if I turn/move the view.

And an other problem is that surfaces of blocks are from one side invisible.

Hi @Micha,

I’m not able to reproduce this. Could you send me the model in your screen shot? If not, could you tell me the minimal steps to reproduce the issue from a fresh scene?


Fresh file - create cube - custom material like at the screenshot. Quick scroll zoom or turn cause the strange effect.

I also noticed that bug recently

Everything points to this having been fixed after last Tuesday’s BETA went out. If this is still reproducible in this week’s upcoming BETA, please make some noise about it.


yes, seems to be fixed, haven’t been noticing it since the last update.

I still see that effect in latest BETA (Tue) but only in the runtime of the scripts that manipulate/animate the camera (ghosting inside the objects that are transparent). Regular view navigation doesn’t produce these artifacts.


Can you share a script that causes this to happen for you?

Correction - scripts have nothing to do with it. I got confused since the scripts that I used and shown that behavior keep an annotation dot object in the screen.

The culprit is a Dot object. As soon as it is in the model, the transparency ghosting happens. No dots - all works OK. Interestingly this happens here only in rendered mode with some materials that have transparency. Ghosted mode works ok even thought object are semi-transparent.

It has been only a couple of previous builds - before all worked OK with dots and transparency here…

Here is how that looks (and is not a screen-recording lag :slight_smile: ):

I’m still not able to reproduce the bug, even with the Dot in there.


  1. What GPU do you have? Could you paste the text from Help -> System Information…?
  2. Could you attach a file that reproduces the problem?
  3. Could you find the minimum steps required to reproduce the problem in a fresh scene?


Beta from today - same problem. GTX1080ti latest driver

Hi @Micha,

I’m still not able to reproduce this on my GTX 980. Here’s what I would suggest:

  1. Start Rhino and reset the Rendered mode display options.
  2. Restart Rhino.
  3. Try to reproduce the problem from scratch and tell me the minimum required steps to reproduce.

This is to make sure I’m doing exactly the same thing as you do.

Found the problem - I reset to default and anything was ok. I disabled shadow -> ok. Disabled “use advance GPU lighting” -> bug. Enabled shadow - ok.

It looks like disabled “use advance GPU lighting” and disabled shadow at the same time cause the bug. The object is a cube, object material options -> new material -> custom -> transparency set to 50%.

Well, that certainly narrows things down. Unfortunately it is still not repeatable on my machine. I’d be interested to know whether @jarek can reproduce the issue in the same way you have @Micha.

Also tagging @jeff and @stevebaer.

Disabling both will cause a completely different path through the back end… So I can totally understand why the behavior may be different.

However, I just fixed this bug a couple days ago…

…What happens if you turn the World Axis Icon ON in the display mode? Does the problem go away?

The issue with the bug I just fixed is that the OpenGL blending function/mode was left ON in a few routines…and it just so happens that the code that draws the World Axis Icon turns it OFF…which then makes the problem go away. I went the through all of the 3.3 code and I’m pretty sure I got all of the areas where the blending mode was used… It’s possible that turning off both the GPU and shadow settings is causing a path I have not found …yet.

Let me know whatever you guys find and I’ll try to see if I can locate this specific case.


@Jarek @Micha, I’m still not able to produce the problem in the latest build…

I guess what I’d like is your display exported when the problem is happening along with a sample 3dm file… just post them both here.


Note: This is my current build…

(6.0.17328.2571, 11/24/2017)
Beta Lab License

Guys, this looks fixed to me…

I was able to reproduce it on another computer using the 11/20 build…but when I updated to the latest build, the problem was gone…

Confirmed again on another completely different config.