Toolbar layout lost every time I open Rhino

As the title says, my toolbar layout is lost every time I open Rhino.

There was a special occurence today, my laptop shut down after the battery had died, while I was working in Rhino. Maybe this has to do something with the problem.

I’ve updated to the latest Rhino 7 service release candidate just half an hour ago.

I’ve had a similar issue in Rhino 6.

The problem occured for the first time with Rhino 7 tonight. I’ve reset my toolbars twice and it still fails.

I’m using the en-US Rhino.

The computer is set to Deutsch (Schweiz).

Comma is set to point

Please help.

Below is my system info.

Rhino 7 SR2 2020-12-8 (Rhino 7, 7.2.20343.11011, Git hash:master @ d3289272aab6acdf2cb6aaf1869cd9a2d8cb464c)
License type: Kommerziell, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-7-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P4000 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 10-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 457.09
> Integrated acclerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.1\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.20343.11011
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.20343.11011
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.20343.11011
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.20343.11011
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.20343.11011
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - try (Rhino closed) renaming the settings files here:


then start Rhino, set it up as you like, close and re-open… does that work any better?


1 Like

Unfortunately renaming did not help.

I just uninstalled Rhino 7 and I’m going to do a fresh installation. It did not help either and I have to reposition my toolbars after opening a file.

Hi Martin,
I gave up on this many years ago. Rhino used to be the best for customization of ws but around V4 it started to go downhill. I found especially a dual monitor setup was really error prone and never worked for a custom toolbar layout/workspace.
One of the hardest things is ui programming and I think McNeel could use a virus shot I’m disappointed with the lack of ui attention so I just gave up customizing and make sure you back up to a different name and location all your rui files for one day it will all be gone.

1 Like

I would give up if it never worked but the weird thing is it worked for as long as I can remember and then all of a sudden it fails for whatever reason. I just opened Rhino 6 and the toolbar layout is also messed up.

Hello - the developer asks what exact version of Windows you are using - from Windows System Information page. We’ve seen a slight up-tick in these reports, and the thought is that it may be Windows-version related since there has been no change in the code in this area.


using the same version but Pro

Rhino 6

Notification says unable to refresh license

Rhino 7

Using just my laptop screen, I have no problem. I can close and open Rhino and the toolbars are where I put them before.

When extending to my two external displays, the toolbars are messed up.

Hi Martin, are your monitors all using the same dpi setting in Windows? (100%, 125% etc)


I’ve had all my screens at 200 % for a long time and it used to work fine even when switching from three screens to just the laptop screen back and forth. This problem came out of nowhere and it is driving me insane!

Should I get rid of my Rhino 6 installation and perform another clean installation of Rhino 7?

Both Intel and NVIDIA drivers are up to date, yet Rhino notification says my Intel driver should be updated.

I clicked repair and this happened:

But the problem remains:

what I want it to look:

@martinsiegrist - several things… please bear with me:

  1. the developer would like to compare the window position files and RUI files in clean and messy Rhinos - can you please do the following:

Make sure only one Rhino is running.
Arrange the UI to look correct.
Close Rhino.
Go to this location:
make a copy of the file
window_positions-Scheme__Default.xml and call it window_positions-Scheme__Default.xml


window_positions-Scheme__Default.xml and call it window_positions-Scheme__Default_Clean.xml
Make a copy of the RUI file here,

and call it Default_Clean.rui

Next, reopen Rhino - if it is messy, close it, and find the originals of the same files you copied before ,
make a copy of the file
window_positions-Scheme__Default.xml and call it window_positions-Scheme__Default.xml
window_positions-Scheme__Default.xml and call it window_positions-Scheme__Default_Messy.xml

and Default.rui as Default_Messy.rui

And send all of that to me via

  1. A shot in the dark, but please try setting everything up exactly as you like but with the OSnap toolbar closed, and then close and reopen Rhino - does it behave any better?



Just sent the files.

  1. the default.rui file is 8 MB. Two of those resulted in a 17 MB email, not sure if that really went through

  2. closing the OSnap toolbar didn’t help

Thanks, we got the files.


Hi Martin - can you please try the opposite - undock or close the toolbars that are at the bottom, close, reopen Rhino - does that look as you left it on closing? The developer is still suspicious of the docking at the bottom…
(Needless to say we have not been able to reproduce the problem…)


That does not make any difference.

Should I get rid of Rhino 6?

The only reason I think I might need it is for evolute tools but it’s not something I need every day so maybe ?

Hi Martin - - thanks for testing - I would be surprised if having both on the machine would make any difference, but I have not had a good idea yet, so maybe worth a try. What might also be worth a try, if we have not tested this yet, is to block all plug-ins that do not ship with Rhino, close and re-open Rhino…


I’ve had Evolute tools blocked in the last few weeks. Will uninstall Rhino 6 tonight.

I ran into the same problem again yesterday and realised I need to set my toolbars with only the main screen on and all other displays off.

The screen arrangement does seem to have an effect here too.

With my old, smaller screen (3) arranged like this, Rhino toolbar layout is lost.

And with screen 3 higher up it works.