Layouts performance issues

So recently I’ve been having a huge problem with layouts, I don’t remember it being this bad. The file I am working on crashes once in a while whenever I zoom or pan with the mouse. At first I was thinking it could be a file which was too heavy, but it didn’t seem to be the case as it was completely fine in model space, even in perspective. I even tried breaking down the file to 3D and 2D, and combining them in Worksession, but I’m still encountering this same problem. I wanted to raise the question here if someone had an obvious workaround for this which I am not seeing. I’ve already updated all drivers, windows, and bios as well. Thanks.

Hi brnkh,

please run SystemInfo in the rhino command line and paste the results here.

If possible post a file to the forum send to mcneel privately here with a link to this post in the comments.

https://www.rhino3d.com/upload

Thanks

Rhino 7 SR33 2023-8-22 (Rhino 7, 7.33.23234.14341, Git hash:master @ b9f912e46331b381b681e79693b7a3844d72f6e5)
License type: Commercial, build 2023-08-22
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [80% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 Laptop GPU (NVidia) Memory: 6GB, Driver date: 8-14-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.13
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 8-14-2023 (M-D-Y).
> Integrated accelerated graphics device with 5 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-14-2023
Driver Version: 31.0.15.3713
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\b_kho\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.23187.1334

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.33.23234.14341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.33.23234.14341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.33.23234.14341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.33.23234.14341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.33.23234.14341
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\b_kho\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

I also need your email to reply the upload to in the link you sent. Thanks!

That will be sent to tech support email automatically

Oh didn’t notice; it got wiped by autofill.

Just uploaded, thanks!

Can you give me steps to repeat?

I’ve opened your file, tabbed to different layouts, pan zoom etc with no issues.

One thing to try it to disable your Enscape plugin. (File>Properties>Plugins)

Please ensure you are set to high performance video card usage for Rhino.

Hi, so I’ve followed the instructions to set to high performance, turns out the Windows side of things was setting it to auto. It is much more stable now, but I still get a slight lag when quick panning while annotating.

I’m replying this because I just got a crash maybe after about 1 hour of work, no signs or warning, just closed with the Rhino error reporting window. It still happens as before, usually right after annotating or interacting with anything with text in layout space followed by panning or zooming. Tabbing layouts is no issue even before the changes to the graphics setting, panning and zooming does have a slight lag but no longer crashes it out of the blue. I’m wondering, does font type affect the performance? To add on, I can’t disable Enscape, I use it very often for rendering so it would be inconvenient.

Is that with Enscaped enabled?

Is there a particular layer or properties panel active? Ideally we could come up with a step by step way to reproduce.

Nope, Enscape is disabled at this point in time.

Currently I always have the Properties, Layer and Layouts panels open at all times. For the layer it’s on, it’s on 00-_ANNOTATION. For reproducing… I guess you can try copy and pasting/mirroring some of the block labels in layout space, together with leader and annotating followed immediately with quick panning and zooming to other parts of the drawing. Everything else is seemingly okay, like drawing polylines or editing through the detail view, even hatching through the detail view is fine.

Messed around for a few minutes moving panning zooming with no issue. I’ll leave the file open a while and repeat.

This is beginning to look like something graphics card/ display setup. Clean install of Nvidia would be worthwhile. Can we disable the Radeon completely?

How many monitors are you running?

I’m running two monitors, but there is something curious i just noticed. With only the properties and layers panel open, I don’t run into any lag at all. However once i have the layouts panel open, the lag comes back.

EDIT - Lag comes back and remains as long as i open the layout panel once and switch layouts using the panel. Doesn’t go away after closing it. Opened the file again to test, and if I switch using the bottom tabs, this problem doesn’t occur.

Hi Brian -

I see that one of the monitors is connected to the GeForce card, the other to the Radeon. What happens when you connect both to the GeForce, or, for testing, only use a single monitor (that is connected to the GeForce)?
-wim

I cannot seem to get both running on GeForce using the windows settings and the Nvdia settings. I’m actually running a laptop with a secondary screen. The secondary one is the one running on GeForce at the moment.

When I switch to single screen, I am able to replicate the layouts issue mentioned one post above.

Hi, I wanted to follow up if there is any news on this issue. I have isolated it to mostly an issue with the layouts panel. I haven’t ran into any issue at all since not using that panel at all, though that makes switching across layouts a lot more difficult.

hi @briankhoozh I just ran across this thread and opened your file with the layouts. So far it doesn’t crash, but I do notice that zooming in/out on the layouts with the mouse scroll wheel is much slower when layouts panel is visible.
For that I logged: RH-77331 Layouts panel slows down zooming in and out with the mouse wheel

Thanks! Saw your report, interesting though, that when you close your panel the issue is no longer there. For me the issue persists as long as I have opened the panel once. Honestly I’m surprised it crashes because the laptop I have is on the higher end, but aside from that I have no idea what is going on.

Hi Brian -

I’m not seeing any recent crash reports from you but I take it that you are still experiencing those? Please always send in the report when the crash reporter dialog pops up.

Apart from that, a few developers looked at older crashes and they are wondering if it might have something to do with outdated .NET DLLs on your machine. Please make sure to install all Windows updates. From this thread, I don’t see if you have tried repairing the Rhino installation either. You can do that from the Windows Control Panel → Programs → Programs and Features.
-wim