Tiled bump texture on ring

RING 4 with leather XS texture Bump.3dm (2.5 MB) Hi, any advice would be most appreciated. Trying to assign the default ‘leather XS’ bump texture to a surface. I have tried to map it using the cylinder option but it is still coming up as tiled. Please see screen shots and file attached. Thank you
STU

It’s not that the texture tiles, but instead the mapping comes from a box, therefore showing a seam. Your problem comes form the “WCS/OCS Box only” setting of the leather bump map. To make adjustments, you need to change the material type from Metal to Custom in order to control the bump map better (material remains good to use no worry). Then scroll and change that to “WCS/OCS”, and go back to the mapping tab to cancel all previous mappings. It should now display seamless. You can control the size of the bump by changing the "repeat"setting.

you are truly amazing. thank you brother.

Ok so after carefully following your awesome video production, I got most of the way but it stops at thin vertical lines… The only thing that I didn’t replicate from your performance was clicking on the automatically fix something option that came up in the map box

I also redid the geometry using loft as it was messy before