Decal/texture renders in rendered mode but not it Raytrace mode

Aloha,

So I get this glitch occurring on and off. I’ll apply a decal or assign a picture texture to an object and it shows in rendering mode but not in raytrace mode. What is the cause of this and what are the solution(s)? Is this a case of it’s not you, it’s me?

Thanks,

Hello,
I have a similar problem: I want to simulate an embossing in sheet metal using a bump map. The image file is black and white with alpha channel.

  • In Rhino 7 with legacy renderer the bump map appears correctly.
  • Rhino 7 with cycles repeats the bump map endlessly.
  • Rhino 8 with legacy shows the embossing correctly.
  • Rhino 8 with cycles, the bump map is ignored.
    How do I get rid of the rectangular traces of the image border? The alpha channel does not seem to be recognized at all.
    Many greetings, Philipp




Bump in Cycles.3dm (378.9 KB)

here is physically-based material instead of custom, in v7

Bump in Cycles v7.3dm (3.2 MB)

I inverted the texture and changed the bump value to negative, since the border issue you mention is produced when the bump code samples across the edge (bump mapping works by finding the gradient surrounding pixels of the sampled point) of the non-repeated texture

opening the file in v8, we see that the no-repeat option is not yet working:

to work around this, you can increase the size of the texture:

I have also pre-inverted it, and would avoid changing anything else (offset, repeat, etc) in the rhino texture, to try to prevent it generating/using a proxy texture instead of the original texture; instead, I resize the planar mapping to work with the larger texture:

Bump in Cycles v8.3dm (2.5 MB)

1 Like