Bump Map in Rhino Render


#1

Hi Guys,

We’ve been using Rhino Render in our office recently. It seems adding a bump map keeps producing weird dots all over the image. Does anyone have a solution for this. The dots usually disappear if the bump map is turned off.

In the image below, I’ve used the standard Rhino brick material with box mapping applied. Anti Aliasing set to 10x and using the skylight.


(Brian James) #2

I haven’t been able to reproduce this using Rhino 5.1 for Mac (5B161). Can you post the 3dm file? My first thought was that the size of the box map was involved but I haven’t been able to achieve the same look making the mapping widget really big or really small compared to the model.


#3

Hi Brian, Thanks for your response.

I’ve attached the file below and also a screenshot from the saved view. Texture used is the brick from the default Rhino library.

Thanks a bunch!

Test File.3dm (885.1 KB)


(Brian James) #4

Got it thanks! This looks like a bug if the mapping widget is smaller than the object it controls. Rhino 5 for Windows doesn’t show the bug so I’m filing it for the Mac version now.
http://mcneel.myjetbrains.com/youtrack/issue/MR-2459

If you make a new box map for the objects using the bounding box option it will fix the issue. You can also use the Equalize setting in object properties>texture mapping in the right side bar, this will keep the scaling uniform. Everything renders normally here after that.


#5

Thanks a lot :slight_smile:


#6

hi brian,
this bug it cause a lot of more work to me, don’t you think that after more then 8 months could be SOLVED?
sorry if i’m little bit hard but i use rhino for my professional architectural works and i loose a lot of time because i can’t set the texture maps smaller then the objects.
thanks,
roy


#7

Hi Lopez, Brian,

Actually on Rhino 5.4 it still stay that bug… and each time checking Zenithal light for rendering, the viewport put as render mode, show every material which has a bump map configured… blue !!!
Zenital light produce like a “multiplier” between diffuse map and bump map…producing like a fake normal tex…

It disappears when rendering, but it stay the bug of weird dots on image…
These dots appears on limits of base texture… so it is very problematic with seamless texture which are actually “framed” with dots

Please let us know if it could solved…

Thank you


(Dan Belcher) #8

This ought to be fixed in the latest RhinoWIP for Rhino 6 for Mac. Can you please give it a try and see if you are still experiencing the bug?