(Bug?) Bump map is screwing with environment map in Rhino and RhinoWIP

I’m using a square environment map to simulate a studio environment, so that my object looks nice in the “rendered” view without having to actually render. When I apply a bump map and turn the intensity up, the tiling of the environment changes. This does not happen if the environment is 1024x2048 (not square).

The size of the bump map doesn’t matter.

Before and after screens:

Here’s my environment image if you want to try this.

Software information

Software versions
Rhinoceros version: 5.2 WIP (5C146w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.11.4 (Build 15E65)


Third party kernel extensions
tc.tctechnologies.driver.Saffire (4.3.0 41017) 3563D1B5-FFE0-380D-B232-6D2D6CF819F7
com.Cycling74.driver.Soundflower (2) 2D779840-7439-31E5-8A66-D786C3F47B75
org.pqrs.driver.Karabiner (10.18.0) E6E09313-87A6-30F6-94BE-61DA4EC19A8D
com.paceap.kext.pacesupport.snowleopard (5.9) D8A40112-4EBF-B268-D83A-4F55E54C5F68
com.aladdin.kext.aksfridge (1.0.2) DE061DF5-F2B9-27A7-8F9B-C85C930D828E

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3820QM CPU @ 2.70GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA- 310.42.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: High

I haven’t been able to reproduce this but my suspicion is that it has to do with the bump map image you’re using. I used a concrete type bump map and your angular emap as shown and it appears to be working correctly. Is this still an issue for you?

Still having the issue. Used slightly different environment map this time. Again, the tiling seems to shift only if the environment map is square. The dimensions of the bump map don’t seem to matter.

Here’s a video, notice how the tiling changes when I turn the intensity up.

Thanks for the video… I was able to reproduce the issue and filed http://mcneel.myjetbrains.com/youtrack/issue/MR-2698

I think I missed it before using a filleted box and too much bump. The developers will need to look into this one but in the meantime I found you can use a single angular map/light probe in render properties>environment to get this to work. You’ll need to have some reflection value in the material as well.