The render display mode goes nuts in the new WIP

I’m not seeing that here in Rhino 6 SR0 2016-1-7 (Public Build, 6.0.16007.431

Post your OpenGL info…

Why is this stuff private? Seems like a good post to see if other users are experiencing the same issue.


Happy New Year…

Here is my config on Rhino, hope this helps…


Agreed, I changed the category Andres chose

Looks like your Rendered display mode is customized. Can you save a copy of the ini and then set it back to defaults. Any change after that? If so, can you post the ini with the issue here?

See if setting your Rendered display back to defaults fixes it.



Here is my INI

Thanks for checking

Rendered.ini (10.3 KB)

That’s just Rhino’s default Rendered mode .ini file…I see no changes. I’m missing the part on why this seems to be a problem with customizing the display mode. ???

IMO, this looks like another case where the SSAO changes aren’t compatible with this configuration.

I don’t have anything here close toe GTX 460, so I can’t really confirm my assumption…However, turning OFF the Skylight in the Render settings panel would also confirm it.

This was posted earlier this morning by Andres:

I know, that’s how I got here…I still think it’s an SSAO issue nevertheless.

@jeff, Is SSAO your code, or @DavidEranen’s?

@brian It’s sort of both… I wrote it originally…and David has been trying to improve upon it… But I haven’t touched the code in years…so if SSAO is the problem, then it’s probably likely due to his more recent changes.

I’ve asked Andres to confirm this though…haven’t heard back yet.

@brian I take that back… Andres did reply… It’s now looking more like the same issues we were seeing when the shader stack was getting overflowed. Andres confirmed that things were working fine before the new year… Which makes me think it’s probably now due to the decal changes that were just merged by @DavidEranen. I need a comparable GeForce card to be sure… all of the ones I’ve tested here before I gave the go ahead for the merge, worked/work. But I will make sure that’s the case with the very latest source right now.

Here’s what I get using the same drivers for a GTX 680…

…so right now I have no idea what’s going on.

I have a GTX 470 in a box here if that helps. Happy to try it tomorrow or send it to you, let me know.

It seems like the SSAO effect is fine - you can see it underneath the noise. As for the decal changes - the decal code should not really be touched in the shader unless there is at least one decal on an object. This seems to leave two options: The decal code blew up the shader stack space (as Jeff already mentioned), or this is something else.

Let’s keep trying to reproduce this and make sure it’s not a one-person thing.


@BrianJ Yes, please see if your 470 does this using the same drivers… If so, then I’m either going to need to get one, or have you send it to me (or @DavidEranen).

I reproduced the same issue using the GTX 470 and driver 361.43 on Win 10

I tried changing OpenGL settings as well as display mode settings such as advanced GPU lighting in Rendered mode to no effect. Turning off the skylight gets rid of the problem and the default modeling shadows are seen.

Let me know if you want the card.

@BrianJ Awesome, thanks Brian… Do you have another machine that isn’t running Windows 10 you could try it on? I’m wondering if it’s a Win10 only thing… I’ll pull the 680 here and put it in my Win10 machine to see if it happens… If so, we’re good to go, if not, I’m probably going to need your card. I’ll let you know shortly.