Shaded Mode goes Black in 2017-May-16 WIP


(www.cadwax.com) #1

Hi @brian, both rendered and shaded mode freeze my screen. Trying to recover my screen - the viewports turn black after 4view.

You are welcome to connect to my computer if this helps diagnose.

Keith


New in Rhino WIP 2017-May-16
(Brian Gillespie) #3

Thanks for letting us know. @jeff can you please look into this?


(Jeff Lasor) #4

This sounds similar to Andres issue…the one @stevebaer recently fixed… I’m not sure it made it into the WIP though… I’m looking now.

In the mean time @KeithR, I’d like to know what your video hardware is… a screenshot of Rhino’s OpenGL options page should suffice.

Thanks,
-J


(Jeff Lasor) #5

It looks like the fix is in the WIP… so @KeithR I’m really going to need more information from you about your configuration…with some other recent changes that have been going in, many of us have been slamming the WIP using different hardware configs and OS platforms to make sure the new stuff is working, and we haven’t run into this problem yet…So obviously you have a config we don’t have or haven’t tried yet.

Thanks,
-Jeff


(www.cadwax.com) #6

Hi @jeff,

Here is my openGL settings.

Regards,
Keith


(Jeff Lasor) #7

Thanks @KeithR… pretty non-descriptive GPU there… Is this a laptop? Tablet? Desktop?

Also, this just started happening with this week’s WIP? (i.e. last week’s worked fine?)

Thanks again for your feedback and patience,
-Jeff


(Jeff Lasor) #8

One more thing… Which Windows OS are you using?

-J


(www.cadwax.com) #9

Worked fine last week - though a little slow to load rendered/shaded view.

Windows 10 Asus Laptop x551c

K


(Jeff Lasor) #10

@KeithR Just wanted to let you know I haven’t forgotten about you or this… I’m still trying to figure out what changed that could be causing this…so far, nothing is jumping out at me… So it’s possible that this week’s WIP will have the same problem (sorry). None of the 4 Intel GPUs I have here are showing the problem, which makes tracking this down very difficult.

Thanks for your patience on this one.
-J


(www.cadwax.com) #11

@jeff thanks, it is working with this week’s release.

Shaded and rendered are both slow to load the first time (12 seconds) - is this when Rhino is loading openGL settings ? Thereafter switching between them is instant.

Keith


(Jeff Lasor) #12

@KeithR It sounds like you’re seeing the delay hit for loading and compiling all of the OpenGL “shaders”… However, you shouldn’t see this more than once per WIP, as they are stored and remembered the next time you launch Rhino. Given your driver version and OpenGL support, shader caching should be available and should be working.

Does this happen every time you start Rhino? Or did you only see this the first time you started the WIP?

Thanks,
-J


(www.cadwax.com) #13

Thanks for the explanation @jeff - just tested, this is happening every time (not remembered between launches ).

Regards,


(Steve Baer) #14

Shader caching is an OpenGL 4.1 feature. Unfortunately your driver looks like it only supports up to OpenGL 4.0 feature set which is why the shaders need to be compiled every time Rhino launches.


(Jeff Lasor) #15

Thanks @stevebaer… thought it was 4.0 and up… @KeithR it looks like you’re just shy of the supported version…which, unfortunately means they need to be compiled every time Rhino launches, as Steve mentioned.


(Steve Baer) #16

I have experienced this lag on computers that don’t support GL 4.1 and it is pretty painful. I don’t have any good solution for this yet other than spending some time to see if we can do anything to reduce shader complexity on these systems.